9

I have trouble with the numeric keypad (NumLock keys) being unusable while typing.

While I don't think it's GUI specific, this happens both in Gnome and KDE. Sometimes it works in TTY, other times it fails. If I press the NumLock key nothing happens, and the response is the same.

I cannot use any of the keys except Ins, which repeats text after Backspace is used.

EDIT:

xev output, on NumLock press/release

KeyPress event, serial 33, synthetic NO, window 0x2800001,
    root 0x101, subw 0x0, time 389867, (311,217), root:(319,313),
    state 0x0, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x2800001,
    root 0x101, subw 0x0, time 389867, (311,217), root:(319,313),
    state 0x10, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
3
  • What does xev say when you run it and then press numlock? Mar 13, 2012 at 5:30
  • @UlrichSchwarz I have edited the question.
    – Joe Barr
    Mar 14, 2012 at 23:49
  • That looks good, so it appears the keystroke is getting up to the X server, which then doesn't do anything with it. I'm stumped, I'm afraid. Mar 15, 2012 at 6:36

14 Answers 14

5

This command worked for me on Linux Mint and Ubuntu using XFCE with a CMStorm keyboard.

setxkbmap -option keypad:pointerkeys

setxkbmap - set the keyboard using the X Keyboard Extension

For some reason, activating numlock will make the keys move my mouse and deactivating numlock will set the keys to the correct characters. I suppose this is good because now I don't have to enable numlock and I can save a very small amount of electricity.

Source: https://forum.kde.org/viewtopic.php?f=216&t=106658

1
  • This may have changed something... but on my system doing Shift+numeric keypad key does not do what I expect to do: extend selection... Dec 30, 2021 at 17:39
4

If you're using an apple keyboard the problem might be the keyboard not linux. You need to press the "clear" key which is top left of the numeric keyboard to enable numlock. This worked for me on Fedora.

2
  • 1
    This soled it for me! Thanks!
    – dfife
    Nov 29, 2021 at 1:05
  • Solved it for me using the Logitech MX Keys for Mac with Ubuntu 20.04: Shift + Clear.
    – Ralph
    Dec 21, 2021 at 18:19
1

Linux Mint kde. Go to settings, accessability, mouse, unclick box "use mouse emulation" and numpad will be active when NumLock selected.

0

Is this a PS/2 keyboard being accessed from a USB adapter? The inexpensive ones always give trouble on keyboard that draw over 100ma from the system, such as the famous IBM Model M keyboard. For those you need a heavy-duty "active" adaptor, such as discussed at Geekhack, Deskthority and other keyboarding forums.

0

There are some keyboard layouts that just don’t have the numlock key in use. For example the German neo layout which is part of de. Maybe you are using this or a similar layout.

0

Thanks to drewbenn and Ulrich Schwarz for helping me narrow down this problem.

Shift-numlock didn't work disable the mode for me, so I went hunting around the GUI for some sort of manual setting that I might be able to unenable.

In the "mouse KDE Control Module" (KMenu -> Computer tab -> System Settings -> Input Devices -> Mouse) there is a tab called "Mouse Navigation".

Unchecking the box next to "Move pointer with keyboard" solved the problem!!!

0

On Mint Cinnamon the part which changes from the KDE is that you have to go to (Gmenu -> System settings -> Accessibility -> Pointing and clicking )

There turn off the "Control the pointer using the keypad" option.

1
  • Doesn't work as of now. Dec 30, 2021 at 17:37
0

Try this program

https://packages.debian.org/sid/numlockx

On my system works,fine,on X and tty

0

I accidentally disabled the numeric keypad.
To allow the numbers to work again, I did the following:

  1. Go to mouse settings
  2. Mouse/ Touchpad ===> choose Mouse
  3. The "Show position of pointer when control is pressed" checkbox should be in the [off] position
0

Fedora 27= >Settings >Universal Access >Mouse Keys=Off That fixed it when using my USB keyboard with 10 key pad. None of the combinations with "Num Lock" had any effect until I turned Mouse Keys off.

0

Kali-Linux v2018.1:

Universal Access > Pointing and Clicking > Off

These steps will give you the option to turn on numlock manually. This is not to enable automatic numlock on start-up. However, it will give you the ability to once again use the numbers pad.

0

On Fedora 30: Configuration (or Setup, I'm not sure) > Devices > Mouse & touchpad > turn off touchpad. Bingo! Numerical pad is now working!

0

AAAAAAAAAAAAAAAAAAHHHH!!!!

Found it!!! I can hardly believe it... am I dreaming?

For the record: I am using "UK Extended" keyboard layout in a Linux Mint 20 machine with a Cinnamon 4.6.7 desktop. I want to emulate the way the numeric keypad keys behave in Windows, i.e. basically NOT to type numbers, but to navigate the caret ("keyboard cursor") on screen, including, crucially, the ability to go shift+numeric_number = "extend selection".

Your experience will differ no doubt if your OS is different and you want to achieve something different.

On my machine:

  • "start" key --> type "keyboard", Return
  • click the "Layouts" button at the top of the dialog
  • highlight the keyboard you want to work on
  • click "Options" (bottom right)
  • an amazing dialog appears called "Keyboard Layout Options", with about 20 categories of options
  • expand "Miscellaneous compatibility options"
  • check "Num lock on: digits; Shift for arrow keys; Num Lock off: arrow keys (as in Windows)"
  • naturally enough, make sure you haven't inadvertently left any other non-default options switched on (the category labels are helpfully bolded when a non-default option has been chosen)
  • click Close
-1

Nothing suggested above works. I accessed universal access, turned off mouse keys, and the numb pad works again.

2
  • numb pad? ouch!
    – theGtknerd
    May 12, 2019 at 2:01
  • @theGtknerd surely "not ouch", oblivious ...? Dec 30, 2021 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.