1

Using advice from this forum, I got tap to click working in LXDE on my Powerbook G4 running Debian 8.7. I have since been experimenting with the MATE desktop, how do I get tap to click working in MATE?

Thank you.

0

How did you manage to do that under LXDE? It should be no different from that; after all, the technologies at base are the same.

Since LXDE has no specific control panel or anything of the sorts, I suspect you add some command to some startup file? That will work with mate desktop, too. If you can't find any such startup file, you can always use your ~/.Xsession to deal with that. In that file, you'd first have to place the command(s) that configure your touchpad, and after that you'd place the correct command to start mate desktop.

This solution will work for whatever graphical environment you're using, not just mate.

  • To get it working in LXDE, I created a file /etc/X11/xorg.conf.d/50-synaptics.conf and added the necessary commands. I can confirm that this doesn't affect the Mate desktop as I am using it now and I cannot tap to click or use two-fingered scrolling. Both features now work in LXDE. – Simon Baldwin Jan 26 '17 at 17:12
  • But not when I enable the Mate desktop. – Simon Baldwin Feb 27 '17 at 12:03
0

Follow these steps. It worked for me. My notebook is SAMSUMG NP270E5G-KDRBR corei5 Debian9 with MATE

sudo apt-get install xserver-xorg-input-synaptics

sudo cp /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d

After go to: System - Preferences - Hardware - Mouse

click in the tab Touchpad

check the option: enable mouse clicks with touchpad

reboot

I hope this helps.

0

If synaptics isn't working for you, check to see if you have a non-synaptics touch pad:

$ egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices

If you do not find a synaptics touch pad, but one from a different vendor (mine is an Elantech touchpad for example), try the following commands:

$ apt-get purge xserver-xorg-input-synaptics
$ apt-get install xserver-xorg-input-{libinput,evdev,mouse}

$ mkdir -p /etc/X11/xorg.conf.d
$ echo 'Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on"
EndSection' > /etc/X11/xorg.conf.d/40-libinput.conf
$ systemctl restart lightdm

If restarting lightdm doesn't work, try rebooting your computer.

More information: https://wiki.debian.org/SynapticsTouchpad#Enable_tapping_on_touchpad

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.