0

I tried both netctl and NetworkManager.

Copied /etc/netctl/examples/mobile_ppp and added number and APN name as there's no pin/pass/username and set interface to /dev/ttyUSB0 (also tried the other ttyUSB1, and ttyUSB2 as well).

My `/etc/netctl/mobile_ppp` file's contents are as follows:

Description='Example PPP mobile connection'
Interface='ttyUSB0'
Connection='mobile_ppp'
PhoneNumber='*99#'
# Use default route provided by the peer (default: true)
#DefaultRoute=true
# Use DNS provided by the peer (default: true)
#UsePeerDNS=true
# The user and password are not always required
#User='example@yourprovider.com'
#Password='very secret'
# The access point name you are connecting to
AccessPointName='internet'
# If your device has a PIN code, set it here. Defaults to 'None'
#Pin=None
# Mode can be one of 3Gpref, 3Gonly, GPRSpref, GPRSonly, None
# These only work for Huawei USB modems; all other devices should use None
Mode=3Gonly
# ^ tried all other options too

netctl start mobile_ppp "connects" silently with no errors on output and shown on journalctl -xe, but there's no actual connection.

And it also shows * sign prepended on its name when issuing netctl list (as if really connected/operating).

Currently I am connected with netctl but with wls1 (Wi-Fi profile set up with wifi-menu).

Moreover the USB modem is not shown in the nm-applet of NetworkManager, what I installed separately.

Also, the modem's LED turns blue as if connected or operating, but with no results.

I did a lot of research on the web, came across and read wikis and other users asking about similar issues, and tried the solutions, installed many many packages in Arch Linux, but unfortunately nothing worked for me to simply connect with the modem which used to automatically connect on Fedora 25 (without GNOME even).

2
  • lsusb with modem. Is usb-modeswitch usb-modeswitch-data on your system? nmcli d and nmcli c – user192526 Jan 26 '17 at 12:34
  • lsusb shows the modems name and manufacturer, and the three ttyUSB's are shown as well. – user86041 Jan 26 '17 at 16:33
0

I could finally solve it (I'm posting it using the USB connection :P).

Some points to note:

  • wvdial (as configured in /etc/wvdial.conf) could not connect anyhow (couldn't dial with ATDT and ATD commands).

  • netctl created profile, 'connected' (netctl start) without (outputting) errors but there were no real connection.

  • So, I installed NetworkManager, started and enabled it as service alongisde ModemManager (with systemctl start).

  • I installed tint2 (as there's no panel (system tray) in my system) specifically to run GNOME's nm-applet on it, and configured the broadband network, and Network Manager showed it as an enabled device and I could connect through the profile I created on nm-applet (GUI, again).

That's it. Thanks, for :)


NetworkManager won't (probably) connect without ModemManager service.

No matter how hard I'll try I couldn't connect through the default, native netctl that comes with .

I still would like to connect with the native application, if anyone knows how, or can help with it (reading my previous post, or by providing a 'better' profile file for the USB modem (model) noted above), I'd really appreciate that, and switch back to netctl.

But now that the native netctl couldn't/doesn't do the job, I'll have them both installed (what I don't actually like doing for minimalism) as network managers until I could connect properly through the former one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy