1

My Asus Laptop (model n552vw) have a couple of problem with VGA Driver.

I have two VGA, Intel skylake (v6) and Nvidia 960m. and I installed for both the latest driver.

I have no Xorg errors and my xorg.conf is:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

After I installed Ubuntu 16.04 (Kernel 4.4.0-59), the System cannot use the Intel driver and when I remove nomodestteing the System use the Intel but the CPU fan is working at high speed,

I tried to install Ubuntu 16.10 or any other distro with kernel 4.8.X, but the login page freeze.

When I switch to Nvidia the fan speed is normal but movies and games have very very low frame rate.

closed as too broad by Rui F Ribeiro, Isaac, Kiwy, Christopher, Timothy Martin Apr 17 '18 at 16:58

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • i upgrade kernel to 4.6 and not any change – Parazitt Jan 26 '17 at 23:21
  • I have the same problem. Any news? – Glats Jun 12 '17 at 15:29
  • could you provide cpu temp with lm-sensors, cpu fan speed is usually handle by the CPU and motherboard itself it could be influence by software but most likely it's just because your CPU is hot or your thermal paste in bad shape – Kiwy Apr 17 '18 at 9:40