I'm using the Awesome Window Manager together with Gnome in Linux Mint. I experience the following problem several times a day:

Suddenly the mouse partially stops working, which means that I'm still able to move the cursor, but any mouse clicks won't do anything. Moreover, the cursor doesn't change when it should, e.g. when hovering over links.

This state doesn't change until restarting the computer or restarting the X server with Ctrl+Alt+Backspace.

Despite this the system works quite normal. (I'm writing this message without mouse at the moment)

I think it's very unlikely that it is the mouse as changing the mouse doesn't change the behaviour.

To me, it feels a bit like some invisible window was put over the whole screen, or some application "captured" the mouse and didn't release it, but thats only speculation.

I even tried it via TeamViewer, and it shows the same behaviour -- moving works, hovering and clicking does not.

I should mention the problem is global, not limited to any special program.

Now I know when the bug occurs exactly: If I click in a Gtk application (like Nautilus, Gedit, Ubuntu Software Center) somewhere in the menu bar or the toolbar where no menu or button is (e.g., right of the "Help" menu in Nautilus), then this bug occurs. If I close the corresponding application, it goes away.

I'm going to start a new thread for this.

  • 3
    Run xev and check if click events shows up...
    – pbm
    Mar 11, 2012 at 21:41
  • 1
    I have experienced this same behavior in the past, so I don't think it's anything special about any your hardware. I did not have Gnome at the time. I currently have two systems with Awesome, and neither are showing that behavior. Mar 11, 2012 at 23:13
  • 1
    @pbm: I tried it, and no mouse events are shown in xev, but keyboard events are. Mar 12, 2012 at 18:55
  • Something modal is stealing input focus but not showing you the activity? Perhaps a key binding you are unaware of for a run or execute prompt that isn't drawn?
    – Caleb
    Apr 3, 2012 at 13:55
  • 1
    For anyone who was curious like me, Max's other question is: unix.stackexchange.com/questions/34412/… .. but unfortunately it (currently) has no answers. Nov 16, 2012 at 1:06

2 Answers 2


I have this problem as well. I think it's related to the bug herein:


The problem seems to be related to specific functionality in gtk 3.0, likely related to resizing the window or making the resize grip appear: I've gotten this behavior when I use Meta-Mouse2 to resize in Awesome. I've also seen it happening just in the course of regular use. Some things that might help:

1) You can begin closing random gtk windows. In my experience, the problem only reliably goes away when I close my last gnome terminal. I should really find a non-gtk terminal that pleases me.

2) Always run awesome with your windows in some layout rather than free. This will make the resize grip not show up accidentally.

Other than that, I think the best you can do is wait for someone to figure out the code path and fix this problem.

  • Hi, I think you're right with the resize grip, but there is another place where this happens: If I click in a Gtk application (like Nautilus, Gedit, Ubuntu Software Center) somewhere in the menu bar or the toolbar where no menu or button is (e.g., right of the "Help" menu in Nautilus), then this bug occurs. If I close the corresponding application, it goes away. Mar 17, 2012 at 19:35
  • This is definitely interesting, because I recently had a similar problem. It only affected some of the very few Gnome / GTK things that I use. And when I shut off the compositor I stopped having these problems. I am using LMDE with XFCE4 window manager, though.
    – vgoff
    Nov 8, 2012 at 23:24
  • (At least in its current form), you don't have to close random applications. The one you used right before the bug occurred and the one you were going to switch to, or the one you accidentally clicked are the most likely candidates. As the mouse virtually stops working when the bug occurs these windows should be fairly simple to identify.
    – Bananguin
    Mar 8, 2016 at 10:17
  • The link "osdir.com/ml/blfs-support/2011-12/msg00059.html" is broken.
    – Luciano
    Jun 25, 2020 at 19:17

The mouse grab when clicking on any empty area in the title/menu bar in nautilius/evince/gnome-terminal/etc. happens for me on Ubuntu 11.10 / libgtk-3-0 3.2.0-0ubuntu6 / awesome 3.4.10-1 as well.

A killall nautilus or so on the console releases the mouse grab; with Nautilus, just closing the window with a Meta-c does not help.

There seems to be a fix for the resize-handle issue coming up the pipeline for GTK+ 3.3.6, presumeably related?


  • Thanks for sharing your information! I had also found out that killing the application helps. But it's still annoying to have to kill nautilus because it closes all file manager windows, not only the one causing the bug :-( Mar 20, 2012 at 20:16
  • I also found a bug report in Ubuntu's Launchpad, they say it will be fixed in Ubuntu 12.04 (which is released in April). Mar 20, 2012 at 20:17
  • I am seeing this problem in Ubuntu 14.04 as well.
    – miphe
    Aug 11, 2014 at 7:05
  • I see this problem also in Ubuntu MATE 15.10.
    – quant_dev
    Nov 25, 2015 at 10:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .