1

I have dynamips which stucks when the IOS starts with the following:

dynamips -P 7200 c7200-a3jk9s-mz.124-25g.bin

dynamips -P 7200 c7200-a3jk9s-mz.124-25g.bin 
Cisco Router Simulation Platform (version 0.2.16-amd64/Linux stable)
Copyright (c) 2005-2011 Christophe Fillot.
Build date: Dec 21 2016 11:17:47

IOS image file: c7200-a3jk9s-mz.124-25g.bin

mips64_jit_init: unable to create exec area (size 67108864)
NVRAM is empty, setting config register to 0x2142
C7200 instance 'default' (id 0):
  VM Status  : 0
RAM size   : 256 Mb
IOMEM size : 0 Mb
NVRAM size : 128 Kb
NPE model  : npe-400
Midplane   : vxr
IOS image  : c7200-a3jk9s-mz.124-25g.bin

Loading ELF file 'c7200-a3jk9s-mz.124-25g.bin'...
ELF entry point: 0x80008000

C7200 'default': starting simulation (CPU0 PC=0xffffffffbfc00000), JIT enabled.
% Unable to create instruction block for vaddr=0xffffffffbfc00000
insn_page_compile: unable to create JIT block.
VM 'default': unable to compile block for CPU0 PC=0xffffffffbfc00000

The IOS is the one reccomended [1]

md5sum  c7200-a3jk9s-mz.124-25g.bin 
3a78cb61831b3ef1530f7402f5986556  c7200-a3jk9s-mz.124-25g.bin

I've also tried by specifing the amount of Ram (256) as stated in the doc, the idle-pc value, as well as a compressed and uncompressed IOS. Also, i've tried in hypervisor mode and connecting via dynagen...same result.

dynamips version: 0.2.16 on x86_64

What else can I try?

[1] http://docs.gns3.com/1-kBrTplBltp9P3P-AigoMzlDO-ISyL1h3bYpOl5Q8mQ/#h.p7dwjvw8qyi0

0

The issue was related to JIT compiler. Running dynamips with -j made it work, but of course it was too slow. Since the distribution I was using is alpine (www.alpinelinux.org) and it's use PAX, i had to paxmark /usr/bin/dynamips. The latest version of dynamips in Alpine is fixed since the binary it's paxmarked in the package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.