2

Yesterday I installed zabbix server and agent on some of my EC2 Instance (running Ubuntu 16.04) Now I want to add the japanese language interface for my zabbix server (because I'm working for a Japanese company and they asked me to do that)

The problem: when I search for available zabbix package on Ubuntu, I couldn't find it. Besides, I tried to install with this command line

apt-get install zabbix-web-japanese
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package zabbix-web-japanese

So I wonder if there is any ways to add japanese language interface.

@Edit: I tried to install some of the older version of japanese language packge from. I found the 3.0.4 version with rpm format. Since rpm format can't be used to install on ubuntu, I had to install alien to convert it to deb. But after executing the command to convert, i got this error

alien -i zabbix-web-japanese-3.0.4-1.amzn1.noarch.rpm
error: zabbix-web-japanese-3.0.4-1.amzn1.noarch.rpm: not an rpm package (or package manifest)
Error executing "LANG=C rpm -qp --queryformat %{NAME} 'zabbix-web-japanese-3.0.4-1.amzn1.noarch.rpm'":  at /usr/share/perl5/Alien/Package.pm line 489.
  • 1
    That package might only be needed for RHEL - if you try to select the Japanese locale in the frontend, does it not work? – Richlv Jan 24 '17 at 9:14
  • @Richlv Thanks Rich. Finally i found the locale and it worked. I never knew about this before. – The One Jan 25 '17 at 3:20
  • Great, added as an answer so that this does not look like an unsolved issue :) – Richlv Mar 6 '17 at 12:58
0

That package might only be needed for RHEL - selecting the Japanese locale in the frontend should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.