2

I have a problem with the wifi.

I need to plug to power to activate it.

  • LAPTOP ACER ES1-522-223C
  • Debian 8.7
  • firmware-atheros V 0.43 ath9k installed

    lspci --> 02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

I have to plug the power to make it change and I can unplug the power after it starts. Even when laptop goes suspend or any similar mode I need to plug the power to get wifi working again.

When rfkill list after pluging in the power I get the following:

sudo rfkill list 
[...] 
1: phy0: Wireless LAN 
    Soft blocked: no 
    Hard blocked: no 
[...]

I've tried everything I have read and I am beginning to suspect that it could be a BIOS problem or something related to the Fn+F3 key. The idea about the Fn+F3 is not really clear because the other combinations of Fn+FX are working.

  • 3
    Hello and welcome. I give you an upvote for your question and answer. But keep in mind, that it's common practice not to answer your own question. Better edit your original post and insert your solution there, via Update: ... – FloHe Jan 24 '17 at 0:44
  • Thank you, i understand. You're right. I did it because this question was holded at askubuntu because i use Debian. As i had to move the question i also broguht my own answer. – Ramon Jan 24 '17 at 7:21
2

[SOLUTION]

Really easy. It works fine even though the Fn+F3 keys have no effect.

I added the blacklist-acer-wmi.conf file to the modprobe.d directory and the blacklist option set to acer_wmi. after that reboot.

Run this command.

echo "blacklist acer_wmi" | sudo tee /etc/modprobe.d/blacklist-acer-wmi.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.