2

I have a .dmg file meant for Mac, I'm trying to get the contents from it (it's Microsoft Project Manager, if that matters) but I can't figure out what to do. I've made a .img copy using dmg2img, and I've tried mounting the .img using mount -o loop, but I get this error:

mount: wrong fs type, bad option, bad superblock on /dev/loop0, missing
codepage or helper program, or other error

when I type file SDM.dmg, I get this:

SDM.dmg: zlib compressed data

and on the .img version:

SDM.img: DOS/MBR boot sector; partition 1 : ID=0xee, start-CHS (0x3ff,254,63),
end-CHS (0x3ff,254,63), startsector 1, 39259 sectors, extended partition table (last)

Is mount the wrong command to use? Is there something else I need to do before mounting it?

-1

This link might help. First, decompress the file using 7z:

7z x image.dmg

Then, mount it with:

sudo mount -t hfsplus foo.hfs /path/to/dir

I also found this post related to the same file type and opening it on linux

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • While this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference – Stephen Rauch Jan 24 '17 at 7:58
  • The links worked, I had to use 7zip to extract the files, then mount the .hfs file. Thank you! – Natterser57 Jan 24 '17 at 13:16
  • @StephenRauch Your comment appears to say that the essential parts should be somewhere else (By having the word “here” as a hyperlink). It is only when we traverse the link that we get the meaning of your comment. Thus making your comment an un-example, of what you are saying. – ctrl-alt-delor Jan 25 '17 at 9:01
1

After converting the .dmg to img through dmg2img , you can mount the img file as follows:

mkdir /mnt/img_mnt
mount -t hfsplus your_file.img /mnt/img_mnt

Some packages need to be installed to easily manage img files .

e,g: On debian based distro you should install hfsplus, hfsprogs packages.

On Rhel : kmod-hfsplus

  • I'm using Debian. I tried your solution, but even with the hfsplus and hfsprogs packagers, I still got the same error: mount: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error – Natterser57 Jan 24 '17 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.