9

I have a problem with the certificates in Arch linux. It seems that it can't find ca-certificates.crt. I have updated my system and installed the ca-certificates{,-utils,-mozilla} packages and it still doesn't work.

git clone http://github.com/sstephenson/bats.git
Cloning into 'bats'...
fatal: unable to access 'https://github.com/sstephenson/bats.git/':     error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
16

I am posting an answer to my own question because I solved the problem and I did not find a valid solution elsewhere. There is no /etc/ssl/certs/ca-certificate-crt file. So a link needs to be provided to the proper cert.

$ ln -s /etc/ca-certificates/extracted/ca-bundle.trust.crt /etc/ssl/certs/ca-certificates.crt

Now I can curl and git clone through https.

2
  • 2
    certbot was broken for me after March 2017's ca-certificates-utils 20170307-1 "manual intervention" update fix. This fixed certbot.
    – Roshambo
    May 29 '17 at 20:56
  • 2
    Thank you! Once again the answer to a mythical problem is found in a lone stackexchange Q&A. This sovled certbot error for me OSError: Could not find a suitable TLS CA certificate bundle, invalid path: /etc/ssl/certs/ca-certificates.crt Nov 7 '17 at 23:01
0

I had the same problem with attempts to git clone from AUR. As with pianomanfrazier, creating a symlink resolved the immediate issue. However, I found that docker was still unable to pull, throwing the error:

docker: Error while pulling image: [image name]
x509: certificate signed by unknown authority.

Removing the symlink and running pacman -S ca-certificate-utils appeared to fix the underlying problem. (Noting docker needed a systemctl restart docker for the fix to take effect.)

Not the answer you're looking for? Browse other questions tagged or ask your own question.