0

I have an ubuntu (16.04) EC2 instance that currently has the /home directory mapped to an EFS drive (Amazon's NFS). I now want to add another EFS drive at /data. I can do so using the mount command with no issue. However if I add the drive to my fstab file to mount on reboot, neither the /home or /data drive will mount. Any thoughts??

Below I posted the fstab file and syslog contents below from when I tried mounting both EFS drives after a reboot.

/etc/fstab

LABEL=cloudimg-rootfs   /    ext4   defaults,discard    0 0
fs-XXXXXXXX.efs.us-east-1.amazonaws.com:/ /home nfs4 nfsvers=4.1,rsize=1048576,wsize=1048576,hard,timeo=600,retrans=2 0 0
fs-XXXXXXXX.efs.us-east-1.amazonaws.com:/ /data nfs4 nfsvers=4.1,rsize=1048576,wsize=1048576,hard,timeo=600,retrans=2 0 0

cat /var/log/syslog | grep -i nfs

Jan 23 02:49:06 ip-XXX-XXX-XXX-XXX kernel: [    4.414135] RPC: Registered tcp NFSv4.1 backchannel transport module.
Jan 23 02:49:06 ip-XXX-XXX-XXX-XXX systemd[1]: Starting Preprocess NFS configuration...
Jan 23 02:49:06 ip-XXX-XXX-XXX-XXX systemd[1]: Started Preprocess NFS configuration.
Jan 23 02:49:06 ip-XXX-XXX-XXX-XXX systemd[1]: Reached target NFS client services.
Jan 23 02:49:07 ip-XXX-XXX-XXX-XXX kernel: [    8.909581] FS-Cache: Netfs 'nfs' registered for caching
Jan 23 02:49:07 ip-XXX-XXX-XXX-XXX kernel: [    8.934907] NFS: Registering the id_resolver key type
Jan 23 02:50:37 ip-XXX-XXX-XXX-XXX kernel: [   98.946336] NFS: nfs4_discover_server_trunking unhandled error -512. Exiting with error EIO
1
  • You could try specifying 'auto' in the mntopts field, even though 'auto' is the default and usually you would specify 'noauto' to turn it off. Jan 23, 2017 at 4:11

1 Answer 1

1

I saw the same problem and recently fixed it. If you manually mount the filesystem, then check /etc/mtab, you'll probably see a bunch of junk added to the options, e.g. mine became: rw,relatime,vers=4.1,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=172.24.25.xx,local_lock=none,addr=172.24.23.xx

The key insight is the sec=sys bit, that means NFS isn't using any of the GSSAPI/Kerberos authentication stuff. (From context in mailing list issues, I've gleaned the the "-512" error is a generic error for when the "AUTH_GSS upcall" fails.)

You'd expect passing sec=sys yourself in /etc/fstab would fix this, but it didn't work for me. Nor did explicitly putting NEED_GSSD=no in /etc/default/nfs-common.

What did work, following this thread was just blacklisting the rpcsec_gss_krb5 via modprobe.d:

echo 'blacklist rpcsec_gss_krb5' > /etc/modprobe.d/blacklist-rpcsec-gss-krb5.conf
reboot

The other caveat is that this is probably a bug, and should just work. There is, for example, this recent Redhat bug report for "nfs4_discover_server_trunking unhandled error -512" which has been marked as a duplicate of a non-public bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .