3

I'm not running hostapd and can't install it.

I'm trying to turn off a wireless access point from my device such that any third party devices that are currently connected to it drop the connection.

I've tried ifconfig wlan1 down which prevents data being exchanged but the connected third party device still thinks it's connected to my device.

This differs to if I physically walk out of range with the third party device. In this situation the signal strength of the connection reduces until eventually the connection is dropped entirely.

So, is there a way for me to stop broadcasting a WiFi signal via the terminal?

  • How is that AP set up on your device, if you're not using hostapd? Are you sure wlan1 is the interface for the AP? Because setting it down should prevent any communication, just like going out of range. Besides figuring out what is actually going on so you can properly set the right device down, using rfkill might also be an option. – dirkt Jan 23 '17 at 7:14
  • My mistake, I am actually using hostapd. I managed to solve this by simply using systemctl stop hostapd. Interesting to note that the results do differ between using the ifconfig wlan1 down and systemctl stop hostapd though. Using ifconfig stops the data transferring but keeps the connection alive whereas using hostapd completely shuts down the connection. The WiFi interface is definitely wlan1 as reported by iwconfig. – chewflow Jan 23 '17 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.