3

I'm trying to install debian on a laptop, on which I previously had ubuntu with everything working fine.

After trying various ISOs (including firmware, looking at sid, testing, and stable), it always starts with looking for a link on eth0, debian never asks me to select a wifi access point every time I kept on going through the install, at least up to where it asks for the mirrors, but even then, it can't reach them, and still doesn't ask so I kept on going with the bare basiscs install, and am now in the root shell, so I can check some more system info. # ifconfig wlan0 up gives the error wlan0: ERROR while getting interface flags: No such device, which didn't help me much through google and ifconfig only lists eth0 and lo

output of lspci

00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
00:02.0 VGA compatible controller Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
00:13.0 SATA controller: Intel Corporation Device 0f23 (rev 0e)
00:14.0 USB controller: Intel Corporation AtomProcessor Z36xxx/Z37xxx Series USB xHCI (rev 0e)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation Device 0f48 (rev 0e)
00:1c.1 PCI bridge: Intel Corporation Device 0f4a (rev 0e)
00:1c.2 PCI bridge: Intel Corporation Device 0f4c (rev 0e)
00:1f.0 ISA bridge: ntel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
00:1f.3 SMBus: Intel Corporation Device 0f12 (rev 0e)
01:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

Any clues to what it might be and how to fix it?

If there's any more information needed, ofc feel free to ask. I realize this is not completely on topic, and if preferred, I'll bring the question over to unix

  • 1
    You have to include more information, specifically what Wifi chip you have. It's certainly a firmware issue, but it can't be answered until you complete your question. lspci will probably show it, though it depends. When you post questions about hardware it's best to include the relevant technical specifications of the hardware, otherwise people have to try to guess, which is a waste of time. – Lizardx Jan 22 '17 at 22:59
  • yeah, of course, I just wouldn't know what kind of information would be useful. I'll type the output of lspci now – towc Jan 22 '17 at 23:04
  • @Lizardx there. Again, I don't know what else could be helpful – towc Jan 22 '17 at 23:17
  • this question may not have more immediate replies on my side, I've ended up putting ubuntu in it because I had work to do :/ – towc Jan 23 '17 at 0:48
2

https://wiki.debian.org/bcm43xx

Just as a note to people posting issues on hardware, you have to include what hardware it is in your initial posting or nobody can help you or figure out the issue. The revised question contains the relevant information from lspci, which shows this to be the dreaded broadcom firmware issue.

That page covers the issues with broadcom chips. Ubuntu sometimes ships non free or contrib pool drivers and firmware, which is why it worked probably in your ubuntu. I quoted the page here so that the solution is preserved, but read up on it in the link to make sure you don't miss any details.

These drivers are included as modules in Debian kernel images. Firmware from userspace is required for device operation.

Firmware is not packaged by the Debian Project. It must be downloaded and extracted, which can be performed by the firmware-b43-installer, firmware-b43legacy-installer or firmware-b43-lpphy-installer packages during their installation. An Internet connection is required.

Add a "contrib" component to /etc/apt/sources.list, for example:

# Debian 7 "Wheezy"
deb http://httpredir.debian.org/debian/ wheezy main contrib non-free

Update the list of available packages:

apt-get update

Install the appropriate firmware installer package:

For devices with a BCM4306 revision 3, BCM4311, BCM4318, BCM4321 or BCM4322 chip, install firmware-b43-installer:

apt-get install firmware-b43-installer

For devices with a BCM4312 LP-PHY chip (PCI ID 14E4:4315), install firmware-b43-installer:

apt-get install firmware-b43-installer

For devices with a BCM4301 chip or the BCM4306 revision 2 chip, install firmware-b43legacy-installer:

apt-get install firmware-b43legacy-installer
1

The right driver for the BCM43142 is the wl , it can be loaded after installing the broadcom-sta-dkms package following the steps as described here

Broadcom STA is a binary-only device driver to support the following IEEE 802.11a/b/g/n wireless network cards: BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-, BCM43228-, BCM4331-, BCM4360-, and BCM4352-based hardware.

Add a non-free component to /etc/apt/sources.list:

apt-get install lsb-release
echo "deb http://deb.debian.org/debian/ $(lsb_release -sc) main contrib non-free" >> /etc/apt/sources.list

Update and install the linux-headers and the broadcom-sta-dkms:

apt-get update
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

Unload conflicting modules:

modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

Load the wl module:

modprobe wl

If you have some issue with the wl module under the 3.16 kernel version , you should install the newest kernel version from backports.

Known issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.