4

How can I ensure that my screen won't go "black" after given time?

  • KDE, Gnome or Terminal? Please post your X11 configuration. – Nils Mar 10 '12 at 21:01
  • sorry, GNOME/GUI. How can I post my X11 config? – LanceBaynes Mar 10 '12 at 21:04
  • I think that place is pretty generic. /etc/X11/xorg.conf as far as I remember. Just post it into your question, then format it with blockquote. – Nils Mar 10 '12 at 21:21
  • still can't find that file. :) even the find command can't find it. – LanceBaynes Mar 11 '12 at 9:46
  • /etc/X11/xorg.conf is (mostly) optional nowadays, I suppose this is a GNOME power management issue. – sr_ Mar 11 '12 at 9:51
2

If you want to set this system-wide (and desktop-manager agnostic), you'll want to create an entry in /etc/X11/xorg.conf.d/ for your monitor, and set: Option "DPMS" off. Per-user, you could put an xset dpms off in the system startup.

2

Have a look at GNOME's power mgmt settings, gnome-power-preferences, you might stumble upon something similar to this

Power Management Preferences

(The GNOME Power management manual is most helpful, also includes the needed gconf keys to maybe automate the process.)

...but increasing the timeout might be enough already?

Also have a look at this FAQ item, *How do I make my application stop the computer auto-suspending? hinting at the use of the DBus interface of gnome-session to inhibit screen blanking...this blog entry is a decent write-up, just comment if you need more info on this :)

2

I've racked my brain about this for a while. I've found the solution that I keep forgetting, so I'm gonna post it.

In your /etc/X11/xorg.conf file, add this section:

Section "ServerFlags"
    Option    "blank time" "0"
    Option    "standby time" "0"
    Option    "suspend time" "0"
    Option    "off time" "0"
EndSection

All the other suggestions like xset and xterm didn't work for me.

0

There's a distinction between power management (ACPI/DPMS) and simply blanking the screen. I would assume Scientific Linux has all the same components as other EL6 distributions. Here's what I needed in CentOS and RHEL 6.9:

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory --type bool --set /apps/gnome-screensaver/idle_activation_enabled false

It's the Gnome idle activation "feature" that blanks the screen. Of course, there are other ways of disabling this setting such as the Gnome Configuration Editor (if installed):

  • Select Applications -> System Tools -> Configuration Editor
  • When open, select apps -> gnome-screensaver
  • Then on right panel uncheck idle_activation_enabled parameter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.