During a travel through China I have been using expressVPN with Ubuntu 16.04 After uninstalling it, I could not use internet connections anymore. My /etc/resolv.conf looks like this

# Generated by expressvpn
search expressvpn

and I made sure to have a working internet connection as described here: https://askubuntu.com/questions/790745/connected-to-wifi-but-no-internet/790770

ssh and scp do work. http, mail protocols don't.

How can I remove expressvpn configurations? I am not able to gain write access to /etc/resolv.conf even with root priviledges. Thank you for your help.

Edit: The immutable bit was set.


I had the same after an ExpressVPN uninstall. A most unfortunate experience, and clearly negligent behaviour on their part.

This is what you probably need to do.

Remove the immutable bit on the resolv.conf file as follows:

sudo chattr -i /etc/resolv.conf

Then remove all three lines of ExpressVPN, and replace the DNS server either by your own ISP / router IP address, or use a free public third-party DNS server such as Google ( or OpenNIC.

vim /etc/resolv.conf

What you do after this is less clear, and depends on your overall configuration. I believe the best source is https://wiki.archlinux.org/index.php/Resolv.conf . They warn you about a number of progams that have a habit of changing resolv.conf, and that you want to protect against. You can either set the immutable bit again to protect against that, or at least add dns=none in the file /etc/NetworkManager/NetworkManager.conf

In my case everything was instantly resolved, and I had internet access again. Perhaps you have already solved it yourself by now, but for (some) others this may be helpful.


FWIW, I had to do the following also:

# apt remove expressvpn
# apt-get purge expressvpn
# rm -rf /var/lib/expressvpn
# dpkg-reconfigure resolveconf
# reboot

I got the same issue and fixed it by running

sudo dpkg-reconfigure resolvconf

and reboot

source: https://askubuntu.com/questions/784994/resolv-conf-did-not-reset-after-vpn-disconnection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.