2

I'm using Arch Linux (4.8.13-1) on an Acer Spin 5 notebook. WIFI is working, but there are some errors in dmesg | grep ath which I don't understand:

[    2.269128] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    2.546004] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:01:00.0.bin failed with error -2
[    2.546040] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[    2.556185] ath10k_pci 0000:01:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 105b:e0a1
[    2.556192] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[    2.557620] ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[    2.625627] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 93da0176
[    4.406204] ath10k_pci 0000:01:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    4.412611] ath: EEPROM regdomain: 0x69
[    4.412613] ath: EEPROM indicates we should expect a direct regpair map
[    4.412614] ath: Country alpha2 being used: 00
[    4.412615] ath: Regpair used: 0x69

lspci -v shows this information about the network controller

01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
    Subsystem: Foxconn International, Inc. Device e0a1
    Flags: bus master, fast devsel, latency 0, IRQ 280
    Memory at b1000000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

I would like to know how to fix this. I think this might solve some issues I'm having with the controller. I somehow cannot correctly connect to my Universitys WIFI. I thought this might have to do mith these errors which appear in dmesg. I tried NetworkManager, connman, wicd, netctl, and with all of them I could only get an IP-address in the network but no connection to the internet. Same with the Universitys eduroam network. I already tried lots of different configurations, but none worked.

This is the output of iwconfig

wlan0     IEEE 802.11  ESSID:"MY-WIFI"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 3C:7A:8A:F7:A2:C8   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:16   Missed beacon:0

lo        no wireless extensions.

And iwlist scan | egrep -i 'ssid|cipher' gives me this

lo        Interface doesn't support scanning.

                    ESSID:"MY-WIFI"
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                    ESSID:""
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                    ESSID:"20da86"
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                    ESSID:"0856e0"
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                    ESSID:""
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                    ESSID:"\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00"
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                    ESSID:"20da86"
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
  • What is the issue? Please edit the question to include what is wrong and results for iwconfig; iwlist scan | egrep -i 'ssid|cipher' – Jeremy31 Jan 21 '17 at 17:16
  • I just edited it. – herhuf Jan 21 '17 at 17:43
  • I would try turning off power management with sudo iwconfig wlan0 power off and see if you can connect. Networks using TKIP are probably going to be problematic. I don't see any issue with the firmware as these devices only need a couple files, a firmware-4.bin or 5, board.bin and some have a board-2.bin – Jeremy31 Jan 21 '17 at 17:56
  • Okay, thank you, I'll try that. But do you have any idea what causes the error messages in dmesg? – herhuf Jan 21 '17 at 18:11
  • The direct firmware load errors are normal for most users as they won't be using the wifi card as an access point. You could check cat /run/resolvconf/resolv.conf to see what it has for a nameserver listed as mine has always been 127.0.1.1 – Jeremy31 Jan 21 '17 at 20:05
2

I little bit late for a party but I also had to connect to eduroam at some point of time and here is my config that works (for me at least):

Description='Eduroam Tartu Student Village'
Interface=wlp8s0
Connection=wireless
Security=wpa-configsection
IP=dhcp
WPAConfigSection=(
        'ssid="eduroam"'
        'proto=RSN WPA'
        'key_mgmt=WPA-EAP'
        'eap=PEAP'
        'identity="<mylogin>"'
        'password="<mypass>"'
        'phase2="auth=MSCHAPV2 password=<mypassagain>"'
)

And also I receive the same errors as you. Though it causes my wireless card to behave weirdly sometimes. After the last update it even fails to reconnect after waking up from a sleep.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.