1

So I just installed Debian Linux on my PC, no errors during installation, Grub works fine. But at the moment when the desktop should supposedly pop up all I got is an "out of range" message.

I tried Kali both live and after install, and Ubuntu MATE, same problem. I installed different Linux distros on another computer using the same screen no problem.

I tried using xorg.conf for frequency but it gives me only cli and no gui.

I tried installing Nvidia drivers through that cli and nothing.

I already checked other posts on the people who had similar problems but nothing worked for me. The PC works fine under Windows though. I also tried using HDMI cable instead of DisplayPort.

The screen : ViewSonic : VX 2757-mhd refresh rate : 75Hz
Current computer : i7 6700k Gtx 1080
Old computer : Intel Core 2 Duo (forgot which) Gt 420

3

I had this issue, its the nouveau drivers, if you have a new GeForce (1060 in my case) those drivers do not work.

The link below gives a general overview of the steps though is for Fedora (25) in my case. So there may be some slight differences.

Even after installing the drivers, you need to ensure that nouveau ones do not load. Removing them like the below tutorial is certainly a good idea, to ensure they are totally gone.. You're not going to be able to use them anyway.

Nvidia driver install and nouveau removal

I tried using other repositories, etc for install but the only thing that worked for me are the latest stable propriety drivers using:

wget http://us.download.nvidia.com/XFree86/Linux-x86_64/375.26/NVIDIA-Linux-x86_64-375.26.run

Soon as I did everything per the tutorial (which is mainly common sense looking at it), i rebooted expecting the worst and was greeted by the gnome login screen, quite a sight for sore eyes through this ordeal.

  • Yeah it's the new 1080 I'll try this right away – Reda Drissi Jan 21 '17 at 7:29
  • It didn't work but I tried other versions and one of them worked ! Thanks man, I was getting really livid at being stuck with windows for anything besides gaming. – Reda Drissi Jan 21 '17 at 8:16
  • I am not a Debian based Linux user so unfortunately couldn't give you specifics, glad I assisted you on the right track. I am having windows 10 DNS issues so finally totally cracked it and setup primary boot to linux instead, worked fine with my GTX750, but upgrading to the 1060 had broken graphical. Had to boot init 3 until I got this sorted! – Brian Ramsey Jan 22 '17 at 0:25
  • It's fine ! You gave me gave me all I needed man cheers – Reda Drissi Jan 22 '17 at 0:26
  • Even if you have an old card (8400GTS in my case) the nouveau are pretty bad ... – ivanivan Feb 8 '17 at 12:12
0

you have a problem whit video graphics-driver if you have Nvidia card try to follow the link https://www.abiraf.com/blog/installing-nvidias-proprietary-gtx-1070-and-1080-driver-in-ubuntu-1604-how-to-get-around-the-out-of-range-error-and-a-guide-to-do-a-realtime-monitoring-of-your-gpu

P.S link is for ubuntu but work for debian , kali...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.