2

Apparently Motorola's phones have MTP disabled (?) and can't find a way to transfer the files to my computer. Have read a bunch of links and none of them work. Have created the file /etc/udev/51-android.rules (sources 1 and 2) and /etc/udev/69-libmtp.rules (source) as the links show and nothing works.

The 51 file as I have it written

SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", ATTR{idProduct}="2e76". MODE="0666", GROUP="plugdev"

the 69 file as I have it written

# Motorola Moto G (MTP+?)
ATTR{idVendor}=="22b8", ATTR{idProduct}=="2e76", SYMLINK+="libmtp-%k",   MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

Since I am not really sure of what any of it means I have tried changing the ID of the vendor to 03f0 (hp, my computer) (know it makes no sense but I had to try since nothing was working), and the ID of the product to 2e82 a supposedly earlier version of my phone.

Other sources I have read that havent worked link

1

If the MTP function is not available you can transfer your file through FTP.

The easy way :

  • install the Wifi File Transfer application on your android device
  • Start the application , it will give you the username , the password and the url e,g 192.169.1.150:3332 ( the 3332 port should be allowed through the firewall )
  • Open the browser and type 192.169.1.150:3332 , type the password and the username
  • Drag an drop your files ( bidirectional) after giving the username and the password generated by the android application.
  • 1
    Even though that wasn't the question it works for what I want. If nobody has a solution as to how to mount a Moto G then I will give you the point :). Thanks!. – M.O. Jan 23 '17 at 20:58
  • @Mariel Please upgrade libmtp from backports then try to mount your device following the steps describrd on your question packages.debian.org/source/jessie-backports/libmtp – GAD3R Feb 13 '17 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.