After looking through many forums, both here and in the Ubuntu/Debian communities, I still cannot connect to wireless. Here is my situation:

-Dual-booting Mac OS Sierra with Debian Jessie -Had to adjust grub for display by setting acpi=off -Installed and removed several different packages. Removed: bcmwl-kernel-source (Reinstalled as well in the end) Added to deb sources to /etc/apt/sources.list:

deb http://ftp.de.debian.org/debian jessie main non-free
deb http://ftp.de.debian.org/debian jessie main contrib non-free

Installed the following packages:

apt-get install broadcom-sta-dkms firmware-linux firmware-linux-free firmware-linux-nonfree firmware-brcm80211 firmware-b43-installer fimware-b43legacy-installer

Added to /etc/modprobe.d/blacklist.conf:

blacklist brcmsmac
blacklist bcma
blacklist b43
blacklist b44
blacklist ssb

Rebooted and no change. Interface showed up only after the broadcom-sta-dkms installed. I tried uninstalling and installing broadcom-sta-common instead but I lost it doing that so switched packages back.

Finally, ran

modprobe wl

Behavior: I tried with SSID broadcast and without. It doesn't matter what network I connect to, even if there is no authentication required. It can see the networks, even the networks that aren't broadcasting (Sees signal strength), but NEVER connects. I used the netinstall and I heard someone using the full livecd made an install and it worked, but I just want to find the right drivers and be done with it.

  • Install a new kernel from backports e,g : the 4.8
    – GAD3R
    Jan 19, 2017 at 19:39

2 Answers 2


I finally got it working.

Downloaded and installed the Stretch distro netinstall with firmware. After doing that, my display issue needed no fixing. However, even after installing the default dkms package, I still got the same error with wl module.

Then, I went directly to the Debian website and downloaded the .deb package from stretch, and installed it. Sure enough, it worked after that! The only issue I have now is sometimes when I put the computer to sleep, after waking it up I have to manual reconnect to the wireless network I was on. May bring that part to a different thread, but for now my biggest concern is solved.


You need to install a new kernel from backports to solve the wifi issue :

Edit your sources.list

apt edit-sources

add the following line:

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

Save and update your system then install a new kernel e,g:

apt update
apt-get -t jessie-backports install linux-image-4.7.0-0.bpo.1-amd64
apt-get -t jessie-backports install linux-headers-4.7.0-0.bpo.1-amd64


Install linux-base from backports:

 apt-get -t jessie-backports install linux-base

Reboot and reinstall broadcom-sta-dkms :

apt-get remove broadcom-sta-dkms bcmwl-kernel-source firmware-brcm80211 firmware-b43-installer fimware-b43legacy-installer

apt-get install dkms build-essential
apt-get -t jessie-backports install broadcom-sta-dkms broadcom-sta-source broadcom-sta-common

and reload the wl module:

rmmod wl && modprobe wl
  • 1
    I got down to installing the image package and got the following: The following packages have unmet dependencies: linux-image-4.7.0-0.bpo.1-amd64 : Depends : linux-base(<= 4.3~) but 3.5 is to be installed. E: Unable to correct problems, you have held broken packages Not sure if I should remove linux-base :O Jan 19, 2017 at 20:03
  • Ok so I tried the above and let me say firstly this definitely fixed the super tiny icons on my desktop, and I no longer have to add additional options into grub2. Yay! :D. However, it appears the wireless card isn't even showing up anymore, and I uninstalled bcmwl-kernel-source, and attempted to reinstall, but I get the below: ` Package bcmwl-kernel-source is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Jan 19, 2017 at 20:47
  • Also, wl doesn't work either: modprobe: ERROR: ../libkmod/libkmod-module.c:816 kmod_module_insert_module() could not find module by name='wl' modprobe: ERROR: could not insert 'wl': Function not implemented modprobe: ERROR: ../libkmod/libkmod-module.c:960 command_do() Error running install command for wl modprobe: ERROR: could not insert 'wl': Operation not permitted Jan 19, 2017 at 20:51
  • It is installed. I even reinstalled. Still no dice :( Jan 19, 2017 at 21:00
  • What is the output of insmod wl.ko ?
    – GAD3R
    Jan 19, 2017 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .