12

I'm trying to install awesome 4.0. To install all the dependencies I ran sudo apt-get build-dep awesome. If I run make in my awesome directory there are some libs still missing:

$ make
Running cmake…
-- git not found.
-- asciidoc -> /usr/bin/asciidoc
-- xmlto -> /usr/bin/xmlto
-- gzip -> /bin/gzip
-- ldoc -> /usr/bin/ldoc
-- convert -> /usr/bin/convert
-- Checking for modules 'glib-2.0;gdk-pixbuf-2.0;cairo;x11;xcb-cursor;xcb-randr;xcb-xtest;xcb-xinerama;xcb-shape;xcb-util>=0.3.8;xcb-keysyms>=0.3.4;xcb-icccm>=0.3.8;xcb-xkb;xkbcommon;xkbcommon-x11;cairo-xcb;libstartup-notification-1.0>=0.10;xproto>=7.0.15;libxdg-basedir>=1.0.0;xcb-xrm'
--   No package 'xcb-xrm' found
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
  awesomeConfig.cmake:153 (pkg_check_modules)
  CMakeLists.txt:17 (include)

I checked which package I have to install to close this gap apt-cache search xcb-xrm but I got no results. Then I checked the dependencies list from awesome, there is only a entry xcb-util-xrm so I was looking for apt-cache search xcb-util-xrm`. I got also no results. How to install the missing library?

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial
5
  • What distro and version are you using? Jan 19, 2017 at 13:38
  • @steeldriver ubuntu 16.04.1
    – Hölderlin
    Jan 19, 2017 at 15:30
  • As far as I can see, the package did not become available until 16.10: see packages.ubuntu.com/… Jan 19, 2017 at 15:38
  • @steeldriver that means I have to build and install from source?
    – Hölderlin
    Jan 19, 2017 at 15:39
  • @Hölderlin this seems to have been answered. Do you still want it migrated?
    – terdon
    Jan 20, 2017 at 10:54

2 Answers 2

11

It seems like the command is:

sudo apt-get install libxcb-xrm-dev 

instead of:

sudo apt-get install xcb-util-xrm
3
  • 1
    Always better to use a standard package whenever you can. I found that this is now available on 17.10. Thanks Akhi.
    – moodboom
    Oct 17, 2017 at 13:16
  • I did this, but no luck. E: Unable to locate package libxcb-xrm-dev. Trying to compile awesomewm in Ubuntu 14.04
    – nephewtom
    Nov 18, 2017 at 21:15
  • 1
    I did some Google search and according to github.com/Airblader/i3/wiki/Compiling-&-Installing, it seems like you need to grab it from a ppa. Hope this helps.
    – Akhi
    Nov 20, 2017 at 20:32
9

As mentioned by steeldriver, the package is not available until 16.10.

One option is to built it manually from source (github)

A Second option would be to get it from a 3rd party ppa

sudo add-apt-repository ppa:aguignard/ppa
sudo apt-get update
sudo apt-get install xcb-util-xrm
4
  • how do you find this third party ppa?
    – Hölderlin
    Jan 19, 2017 at 16:18
  • Google "[package] site:launchpad.net", click on the first result and scroll down to the end of the page and look for the green text that says "Other versions of '[package]' in untrusted archives", click on it and it will reveal a list of all ppa's containing the package Jan 19, 2017 at 16:45
  • 1
    I did this, but no luck. E: Unable to locate package xcb-util-xrm. Trying to compile awesomewm in Ubuntu 14.04
    – nephewtom
    Nov 18, 2017 at 21:16
  • 3
    It should be sudo apt-get install libxcb-xrm-dev instead
    – Tiddo
    Jul 10, 2018 at 10:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .