I have a Raspberry Pi directly connected to a Windows 98 machine with a crossover Ethernet cable. I have made a shared directory on the Windows 98 machine (completely open). The problem arises when I try to mount the shared folder on the RPi.

The commands I have tried are as follows:

  1. sudo mount.cifs //<ip-adress>/share /mount/directory -o port=#
  2. sudo mount -t cifs -o guest //<ip-adress>/share /mount/directory
  3. sudo mount -t cifs -o port=# //<ip-adress>/share /mount/directory

All of these give me the same error: "Host is down".

I can ping the windows 98 from the Pi and vice versa; a nmap scan also shows that the two can talk together.

If I open the file manager, I can access the shares:

enter image description here

And from there I can create and delete folders, files etc. The problem, however, is that I need to be able to access the share using a path to run my backup script.

What am I doing wrong?


You're getting such error because when browsing from the file manager you're actually using smbclient, which works fine on old smb version. Unfortunately smbfs and the smbmount command, which were working fine, have been deprecated and replaced by cifs and its mount.cifs, which don't work at all with older shares. I'm on the same boat and haven't found a solution so far, sorry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.