1

I have GalliumOS installed (a Ubuntu variant), and it's been working fine for a while (probably been ~ 1 month since a fresh install). Some time ago (probably at least 2 weeks ago), some update (I think to GRUB2) required I select an install location/something along those lines. I chose something like /dev/sda7 potentially (I really can't remember the specific place), which may very well be the issue. Since then, whenever I boot I got a GRUB screen asking me to pick from 1 of ~4 options for booting, which was annoying but I never got around to trying to fix it.

Yesterday, I was unable to boot to my install, with an issue very similar to this one. Essentially, the screen would print two lines: The first saying "SeaBIOS (misc version numbers I can copy down if needed)", and the second saying "Booting from Hard Disk". Here, the system hangs.

I made a GalliumOS liveUSB successfully, and am able to boot off of that (when it's plugged in, GRUB gives me two options, the SSD and the USB. The SSD still hangs, the USB works fine). How can I go about repairing the SSD's GRUB thing? I've found this which details how to do it with an Ubuntu liveUSB - will this work (provided I make a Ubuntu liveUSB) even though my install on my computer is GalliumOS?

  • That looks like exactly the right thing to try to me. – airhuff Jan 19 '17 at 1:08
  • I've made a 14.04 live USB, and tried installing and running boot-repairon it, but get the error that the current system is in legacy mode, and I should use uefi. I don't believe this is possible on a chromebook without a firmware update (they use core boot I think? Don't know a ton about it). Is there a tool I can use within legacy mode to fix the grub? – Mark Jan 19 '17 at 2:20
1

I ended up (re)making a GalliumOS live USB, then followed the instructions here. The most relevant bit is copied below:

sudo bash

mkdir /tmp/a

## set GALLIUMOS_ROOT according to your model and original install method
GALLIUMOS_ROOT=/dev/sda7       ## chrx Haswell or Broadwell
GALLIUMOS_ROOT=/dev/sda1       ## ISO  Haswell or Broadwell
GALLIUMOS_ROOT=/dev/mmcblk0p7  ## chrx Bay Trail, Braswell, Skylake
GALLIUMOS_ROOT=/dev/mmcblk0p1  ## ISO  Bay Trail, Braswell, Skylake

mount $GALLIUMOS_ROOT  /tmp/a
mount -o bind /proc    /tmp/a/proc
mount -o bind /dev     /tmp/a/dev
mount -o bind /dev/pts /tmp/a/dev/pts
mount -o bind /sys     /tmp/a/sys
mount -o bind /run     /tmp/a/run

## then

chroot /tmp/a /bin/bash

## reinstall GRUB: internal disk device ONLY :)

dpkg-reconfigure grub-pc

## You might also get some additional prompts:

##  - empty "Linux command line" (OK)

##  - keep the local version of the GRUB config (YES)

exit

reboot

I wasn't able to confirm what the internal disk device only means, from here it appears to mean /dev/sda. I accidentally selected /dev/sda and /dev/sda7, but it worked so I won't mess with it again unless it breaks again.

Edit: it broke again at some point (a few days after the fix). Only select /dev/sda.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.