1

I want to compile a library that need gcc 4.8 or higher. how can I install it on wheezy (32bit)?

# apt-get install gcc-4.8
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gcc-4.8
E: Couldn't find any package by regex 'gcc-4.8'
2

You can't, at least not easily.

The version of gcc shipped with wheezy is 4.7.2. That means there is no (precompiled) gcc 4.8 available for Debian wheezy.

You could compile your own version of gcc and try to do it that way, but that's a lot of work and not at all guaranteed to work. It might be easier to just upgrade to Jessie instead, which comes with gcc 4.9.

  • It may be worth checking the wheezy-backports releases to see if it is there... However I recall something about the kernel series for Wheezy not being compatible with the latest gcc... – ivanivan Jan 21 '17 at 17:24
  • @ivanivan backports does not carry something as core and as crucial as gcc... – Wouter Verhelst Jan 22 '17 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.