3

I was previously using arch linux, lightdm, and sway (an i3 clone for wayland, basically). However, at the time lightdm would not launch sway for me, so I ended up switching to a tty (ctrl+alt+f#) and launching sway from the command line. This worked, and launched sway so as to use both monitors.

Due to something (probably user error) causing my arch install to not boot, I finished making the switch to gentoo linux (I had a partition on my hdd I was using as a staging area).

Upon getting all the general stuff I need normally installed, plus sway, I launched sway to find that only one monitor activated, using the same ~/.config/sway/config file I had been using in arch. The second monitor displayed its 'no signal' message and powered down.

To check that it wasn't something misconfigured as far as gentoo goes (lot of options, lots of ways to mess up), I installed i3 and tried it via startx. It worked fine, using both monitors. I then exited i3, and dropped back to the tty, to find that both monitors were active (they were the same output, but they were both on). Launching sway at this point gave me the results I wanted.

A bit of digging showed that simply launching X and killing it was enough to initialize my second monitor, so I now believe that it was lightdm that was initializing it on my arch install, and it was running in X mode and not lightdm.

For the record, all the way through UEFI, GRUB2, and kernel/openrc init both displays show the same output, only losing display at the point where the login tty shows up.

Any ideas as to how I could fix this?

  • did it get any better? can you point some resources instructing how to config lightdm and sway? thanks – test30 Jul 31 '17 at 18:32
  • @test30 it 'fixed itself' somehow during the process. It was likely some kconfig or use flag I needed to trip. – hanetzer Aug 19 '17 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.