0

I have changed default RDP port on server from 3389 to 1687.

Here is the command I'm trying to connect :

xfreerdp /u:administrator /v:177.8.130.250 /p:1687 /size:1280x700

But it returns this error :

[01:11:14:846] [23825:23826] [INFO][com.freerdp.client.common.cmdline] - loading channel cliprdr
[01:11:14:019] [23825:23826] [ERROR][com.freerdp.core.transport] - BIO_should_retry returned a system error 32: Broken pipe
[01:11:14:019] [23825:23826] [ERROR][com.freerdp.core.nego] - Protocol Security Negotiation Failure
[01:11:14:019] [23825:23826] [ERROR][com.freerdp.core] - freerdp_set_last_error ERRCONNECT_SECURITY_NEGO_CONNECT_FAILED [0x2000C]
[01:11:14:019] [23825:23826] [ERROR][com.freerdp.core.connection] - Error: protocol security negotiation or connection failure
[01:11:14:019] [23825:23826] [ERROR][com.freerdp.client.x11] - Freerdp connect error exit status 1
0

Not a user of xfreerdp, but doc says, that /p: is option for password not for port. To connect to a different port use /port:<port> or /v:<host>:<port>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.