2

I've installed ntp, which put the ntp script in /etc/init.d. On boot, I see that ntp is running:

root@unassigned-hostname:~# ps -ef | grep ntpd
ntp       4142     1  0 21:08 ?        00:00:00 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 101:103

However, if I run ntp-wait, it waits forever. If I run a dpkg-reconfigure ntp, then the call to ntp-wait returns.

So it looks like ntp is enabled, it's running on boot, and if I force it I can get ntp to synchronize. But for some reason it's not synchronizing on boot (at least according to ntp-wait).

What do I need to do to get ntp to synchronize automatically on boot?

  • I'm not in front of a Debian machine at the moment, but it used to be that ntp init scripts would call ntpdate to force the local clock to match a remote servers', then start ntpd to keep it in sync. Separately, ntp-wait may be getting called by dpkg with different parameters that prevent it from waiting forever. – Jeff Schaller Jan 18 '17 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.