2

I have a problem with this library: libXtst.so.6. I work with the eclipse IDE and I want to install scenebuilder-8.3.0-1.x86_64 for Drag and Drop UI in eclipse. When I enter this commend to install scenebuilder

rpm -ihv scenebuilder-8.3.0-1.x86_64

terminal gives me this error:

error: Failed dependencies:

libXtst.so.6 is needed by scenebuilder-8.3.0-1.x86_64

I don't know what it needs of me, but I downloaded and installed libXtst-1.2.2-2.1.el7.x86_64.rpm, but it doesn't work!

4

Instead of downloading the RPM, you can try installing it from the CentOS repositories with the following (as root):

yum install libXtst

That should pull in any other dependencies and update any packages that require that.

If the 64-bit package is already installed then you may need to install the 32-bit library

yum install libXtst.i686
  • Thank you I think its work bcuase installed.but when I type scenebuilder in terminal dosent run anything of sowftware why? – Rayan_LPA Jan 17 '17 at 14:55
  • Please amend your question to include further details regarding your new issue. For example, what happens when you execute scenebuilder? Can you copy the error message to your original question? – stuts Jan 17 '17 at 14:56
0

Try yum instead of rpm. It will resolve dependencies for you:

yum reinstall http://download.gluonhq.com/scenebuilder/8.3.0/install/linux/scenebuilder-8.3.0-1.x86_64.rpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.