-1

The project seems dead and that's a good thing because it was the weirdest tool I'm using in my entire configuration.

Issues :

  • It grabs the keyboard/mouse until you set the right password, preventing you searching a password in a keepass.

  • i3wm shows this as a floating window, and scrap the help display, impossible to set a fixed size. So you need to enter a password without knowing which one is asked for.

  • It looks bad; simple dialog, theming with Xresource... it comes directly from 90's.

The strangest thing is that openssh uses this by default, and setting it to an alternate binary doesn't work.

https://wiki.archlinux.org/index.php/SSH_keys#Alternative_passphrase_dialogs

I tried in .zshrc to put

export SSH_ASKPASS=/usr/bin/qt4-ssh-askpass

But it is still prompting for the default askpass.

Any ideas? An alternate tool or how to tell openssh to use qt4-ssh-askpass binary instead of the default one?

  • I have no idea where did you get that one, but uninstalling it is a good start. Exporting variable should do the job, but from "didn't fix it" I have no idea what is going on. What did you do? What does it do? What do you expect it to do? – Jakuje Jan 17 '17 at 8:52
  • qt4-ssh-askpass is an alternative, mentionned in archlinux wiki as "openssh-askpass" package. I want to use it instead of default x11-ask-pass. Edit the var didn't use the new askpass cmd. (edited) – eoli3n Jan 17 '17 at 13:01
  • BTW, i notice that all of your questions was already answered. what does it do : third points, grabs keyboard, i3wm displays wrong... i did : "tried in .zshrc to put..." i expected : "setting an alternate binary does'nt work" – eoli3n Jan 17 '17 at 13:09
  • Nope. Did you re-login? Did you start new shell/sourced the .zshrc? Does work/does not work is not quite clear. – Jakuje Jan 17 '17 at 13:15
  • Ok, sorry for that. Yep, restarted X, but stupidly forgot to reload zsh in my tty... It works great now :/ are there any other alternative ? not listed in archlinux wiki ? – eoli3n Jan 17 '17 at 13:28
1

To make the changes to environment variables you made in the ~/.zshrc effective, you need to re-login, re-source the file or start a new shell. Otherwise you will be using still the old environment with the old variables.

The features blocking holding focus and preventing opening other stuff, are security features to prevent other applications to get the focus and steal our passwords/passphrase, which should really be something you know, not what you copy from somewhere else.

0

Found some alternatives

  • gnome-ssh-askpass2
  • ksshaskpass4
  • pass-sshaskpass
  • lxqt-openssh-askpass

I now use gnome-ssh-askpass2 which nativly works well with i3wm (it grabs keyboard too :) ).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.