3

I am using an embedded device with onboard storage (mmcblk0).

The system is using UEFI (and GRUB), on mmcblk0 I have a GPT partition with 3 partition: root, configurations, swap.

My command to boot is:

linux /vmlinuz root=/dev/mmcblk0p1 net.ifnames=0 splash

Now my problem is that when I set the quiet or loglevel param, it fails to boot and hangs up in a kernel panic. When I don't set one of those it boots perfectly. Root param is always the same.

Full kernel panic log:

kernel panic log

  • How do you set quiet? Like this linux /vmlinuz root=/dev/mmcblk0p1 net.ifnames=0 quiet splash? – marc Jan 17 '17 at 7:50
  • @mmmint correct. Either before or after splash, Loglevel can be 0-7, no matter which level i set, all end in a kernel crash. – Styler2go Jan 17 '17 at 7:52
0

It seems root FS is not ready when you kernel tries to load it. Use rootwait or rootdelay in your kernel command line should solve the issue.

  • Why do you suppose this would be correlated with the quiet/ loglevel setting?  Please do not respond in comments; edit your answer to make it clearer and more complete. – G-Man Dec 19 '18 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.