0

I'm using Kali Linux for my pentest environment. To my needs, I found that XFCE is a better alternative as an interface for the distro & I particularly like it as it is.

However, lately I noticed .. I'm not able to tune the settings for the lockscreen which presently turns on after 2 minutes of idle time. I wanted to change this into turn off.

I did my research:

  1. There is no way my system settings show me an option to tune this.
  2. I used the CLI for xscreensaver-demo as posted in XFCE forum to no avail.

Here's my lock application:

root@foxtrot:~# ps -ef | grep lock root 27 2 0 qun14 ? 00:00:00 [kblockd] root 705 1 0 qun14 ? 00:00:00 /usr/sbin/vmware-vmblock-fuse -o subtype=vmware-vmblock,default_permissions,allow_other /var/run/vmblock-fuse root 855 839 0 03:13 pts/7 00:00:00 grep lock root 1210 1178 0 qun14 ? 00:00:01 light-locker root 1316 1202 0 qun14 ? 00:00:00 /usr/lib/i386-linux-gnu/xfce4/panel/wrapper-1.0 /usr/lib/i386-linux-gnu/xfce4/panel/plugins/libactions.so 16 10485791 actions Action Buttons Log out, lock or other system actions

I need to know how do I find the power manager options in order to get this disabled?

4
  • remove xscreensaver completely. Jan 16, 2017 at 21:54
  • The xscreensaver application never existed. It gives me command not found. It never shipped with this version. Jan 16, 2017 at 21:55
  • then remove the package which brings you that lockscreen. Jan 16, 2017 at 21:56
  • my ps -ef shows the several ones which I have had mentioned at OP. Not sure, which ones to have uninstalled. Also, wouldn't it have aftereffects? Additionally, can you let me know what command do I issue to bring up the power options utility or atleast find which power manager does XFCE4 use? Jan 16, 2017 at 21:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.