0

OS : Debian Jessie 8.5.0

During setup, I defined a password for root and a primary user account. Now, Gnome has only a standard account with restricted access.
I can't unlock settings, install an application, launch terminal, connect to a new wifi, etc.

I am also not able to manage user accounts since window is locked.
It's asking for an administrator password, root's and any sus don't work.

Is there a way to change my primary account type in a terminal logged in as root ? Else, how to create an administrator account in my case ?

  • 1
    Are you saying that your standard user, can not even open a terminal? (is this correct?) – ctrl-alt-delor Jan 16 '17 at 17:48
  • edit : I'm sorry if I wasn't clear. The terminals ctrl - alt - fx run fine. When I try to open a terminal from gnome desktop application, I get prompted to enter an administrator password. – randomhopeful Jan 16 '17 at 21:57
  • are you starting the terminal by selecting terminal or root-terminal? – ctrl-alt-delor Jan 17 '17 at 8:37
1

Debian installs usually create a root account, with a root password and a non-privileged user account with another password.

When you are trying to access the system settings that need authentication, it is probably utilizing sudo.

The way this usually works is that you do something like access the network manager settings and it asks you for your user password to allow you to sudo to change those settings. Here you enter your user password, not a root password.

If your user password does not work here you might have to set up sudo to allow your user to run commands as the super user (root). You can do this one of two ways:

  1. Log in a root and add your user to the sudo group:

    adduser derp sudo

where derp is your user name, or

  1. Edit the sudoers file to allow your user to run sudo commands. Here you will need to consult the man page for visudo and make an entry in the sudoers file for your user.
  • If you don't want to break things, then use method 1 (add user to group sudo). – ctrl-alt-delor Jan 16 '17 at 17:46
  • Method 1 doesn't work. I came across the steps in a couple of help forums and I followed them. Downloaded the sudo package, added a super user, updated the sudoer file. Still, the account remain standard in gnome and doesn't do much. – randomhopeful Jan 16 '17 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.