1

I installed vim version 7.4.1689 in my linux mint 18. I opened any file with vim but after switching between modes on the status bar it is not showing anything like which mode I am currently in. I searched everywhere for the solution found one but it did not worked. The solution given was to use the command:

:set showmode this is my insert mode

in /.vimrc file, I did that but nothing happened, can somebody please help me to solve this issue.

8
  • What's the answer to :scriptnames and :set showmode? ?
    – AlexP
    Commented Jan 16, 2017 at 11:22
  • I did not get you? Can you please say clearly?
    – Shivam
    Commented Jan 16, 2017 at 12:51
  • In Vim, enter the commands :scriptnames and :set showmode?. They should list the names of the scripts which have been sources and the current state of the showmode option. What do those commands return?
    – AlexP
    Commented Jan 16, 2017 at 12:52
  • :scriptsnames - returned a list of scripts
    – Shivam
    Commented Jan 16, 2017 at 12:59
  • And :set showmode returned - "showmode"
    – Shivam
    Commented Jan 16, 2017 at 13:00

2 Answers 2

0

Maybe this one will work

:set laststatus=2
0

You can try turning off bold color option from profile under text tab.

Otherwise use

:set showmode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .