2

I have just installed Centos 7 on VMware as a quest on Windows. Surprisingly centos 7 does not install the network (i.e. no internet) after install (unlike previous versions of centos). I have gone through the centos forum and have not been able to find an answer. When I try

nmcli d

I get

DEVICE TYPE STATE CONNECTION
lo loopback unmanaged --

I have tried several other commands and they take me nowhere. I copied the following rpm packages from the installation iso image:

NetworkManager-1.0.6-27.e17.i686.rpm
NetworkManager-config-routing-rules-1.0.6-27.e17.i686.rpm
NetworkManager-server-1.0.6-27.e17.i686.rpm
NetworkManager-devel-1.0.6-27.e17.i686.rpm

I installed these with

rpm -Vuh "package"

The first three showed an indication of being installed. The fourth did not install due to dependencies.

nmcli d

gives the same result.

system-config-network 

gives command not found. I am really stuck. I see the same question here enter link description here posted on 13th January 2017, 22 views, no reply. Please help, how can I setup an internet connection?

lspci -nn |grep -i net

gives

02:01.0 Ethernet controller [0200] Advanced Micro Devices, Inc. [AMD] 79c970 [PCnet32 LANCE] [1022:2000] (rev 10)

Here is the output of output of

lspci | grep -i net

02:01.0 Ethernet controller [0200] Advanced Micro Devices Inc. 79c970 [PCnet32 LANCE] [1022:2000] rev 10)
02:02.0 Multimedia audio controller [0401] Ensoniq ES1371/Creative Labs CT2518/ES1373 [1274:1371] (rev 2)
02:03.0 USB controller [0c03]:VMware USB2 EHC1 controller [15ad:0770]
  • From the output of nmcli d it seems the NIC is not recognized, which may be due to missing driver. Could you add lspci | grep -i net to your question. – Thomas Jan 15 '17 at 13:48
  • Go to /etc/sysconfig/network-scripts/ifcfg-"network interface name" and created it. You can define static ip address or DHCP.Using systemctl to enable network and service network start. Dont forget define hostname /etc/hosts – supriady Jan 15 '17 at 15:21
  • 1
    @Thomas is correct, you can also verify that with the ip link command which will list the interfaces. if you don't see your NIC there try replacing the virtual nic via VMware interface to a more generic one like the Intel Pro – Rabin Jan 15 '17 at 15:22
  • Excuse my ignorance, what I have in /etc/sysconfig/network-scripts is ifcfg-lo. Can you assist me with the steps to follow. Do I create another file "ifcfg-anyname" ? what should be the contents of that file. I have done ip link before this post. output was "lo:,LOOPBACK,UP,LOWER_UP> ...and more". I also tried service "NetworkManager satrt" and "chkconfig NetworkManager on" I was prompted for password and it seems to have ok, no complaint. – Zilore Mumba Jan 15 '17 at 15:37
  • The full output of ip link or ip address would very helpful. With that we could identify the next steps. – Thomas Jan 15 '17 at 16:45
1

I faced the same problem and I solved it by adding ethernet0.virtualDev = "e1000" to .vmx file which is by default located in Virtual Machines\YourVM.

0

Hi this worked for me:

Re: CentOS 7 network install on VMWare Workstation problem

(Quote)

Postby Duke Nukem » 2014/08/13 21:29:13

OK, I think this may be a 32-bit/64-bit issue of some kind ? Centos 7 is now 64-bit only.

I'm using Windows 8 64-bit but its not clear (to me) what the VMWare host itself is running (note: the VMWare UI itself is, I believe, always 32-bit regardless of the guest OS it is running).

Anyhow, in VMWare, when selecting the OS do not select Centos, instead select "Other Linux 3.x kernel 64-bit". Doing that I can now select a network device and it appears to work (I can log in via a PuTTy terminal), though not sure what the side effects of this choice might be - guess I'm about to find out :-).

Also during install config of network/hostname I had to switch the connection on and also added a tick for "Automatically connect to this network when it is available".

TTFN, Jon

PS: I also ticked the "Replicate physical network connection state", not sure if that is necessary but hey, it is working. Attachments fix2.jpgNetwork optionsfix2.jpg (30.58 KiB) Viewed 82167 timesfix.jpgSelecting the OSfix.jpg (24.69 KiB) Viewed 82167 times

  • When creating CentOS VMs, I choose RedHat. Basically CentOS is RHEL without the support license. Never had an issue, and we have a few hundred VMs at my day job. – Deathgrip Jun 14 '17 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.