1

I've downloaded kali linux from here osboxes kali linux because I'm having troubles installing any linux version using virtualbox on my windows laptop. I tried to install virtualbox guest additions this way [UPDATE:] I run apt-get update first but nothing to update

apt-get install linux-headers-$(uname -r) -y

but the result is

Unable to locate package linux-headers-4.3.0-kali-amd64
Couldnt find any package by glob 'linux-headers-4.3.0-kali-amd64'
Couldnt find any package by regex'linux-headers-4.3.0-kali-amd64'

I tried to update through terminal and fro settings but tells me all updates are installed and there's no new updates

I tried

apt -y install open-vm-tools-desktop fuse

The result is

Unable to locate package open-vm-tools-desktop

I tried

sudo apt-get -y dist-upgrade

The result

0 upgraded 0 newly installed 0 to remove 0 not upgraded

I'm new to linux just running kali on virtualbox to study CEH but can't update or install packages. So how to fix this?

[UPDATE] I added repositories and managed to upgrade kali then in terminal:

apt -y install open-vm-tools-desktop fuse

The result is "fuse and vm tools are installed and alreadyhave the newest version" but still can't find the shared folder from windows (as I can in Parrot)) and still can't drag and drop files

3

Have you checked which repo you have in the file /etc/apt/sources.list? If you just installed Kali, you might need to replace the cd-rom repos with the standard repos:

deb http://repo.kali.org/kali kali main non-free contrib

As well as:

deb http://ftp.cc.uoc.gr/mirrors/linux/kali/kali-security/ kali/updates main contrib non-free
0

The problem with apt-get install or apt-get upgrade would be fixed by apt-get update. This needs to be run before the first attempt to install packages, or as the first step in any package update. Of course, this may just show you a more specific error.

The update through Settings graphical interface likely uses PackageKit. On your system, it acts as a frontend to apt-get. I'm sorry to say PackageKit can be difficult to understand and troubleshoot. I think you have the right approach in trying to troubleshoot with specific apt-get commands in the terminal, first.

For example, PackageKit has a command-line equivalent to apt-get update. Firstly, you need to know the right options in order to resolve an issue like this: pkcon refresh force or pkcon -c 1 refresh. Secondly, if repos cannot be contacted, it might only list those repos (on Debian), or nothing at all (Fedora IIRC, or if it thinks the computer has no network connection). The pkcon command does not tend to list more specific errors. In theory, PackageKit is designed around updating laptops which may or may not have internet access at a given time. In practice, it fails to handle network interruptions; an attempt to patch this has been submitted some time ago but requires review and has not been responded to at all. https://bugzilla.redhat.com/show_bug.cgi?id=1314991

  • 1
    I did apt-get update first but nothing updated and I don't have a network issue as I can ping yahoo.com and open websites via iceweasel – PHP User Jan 15 '17 at 9:19
  • updated please review – PHP User Jan 15 '17 at 13:00
0

added the main repositories to etc/apt/sources.list

sudo apt-get -y dist-upgrade

reboot

then followed these steps: https://youtu.be/MkaJ3Nssxac?t=5m49s

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.