2

Before even beginning to share the problem, I understand that this issue has been brought up a number of times, on different websites. Literally beaten to death. But unfortunately none of the solution worked for me.

Onto the case in point, I recently installed Fedora 25 (64 bit) on Asus TP300L (planning to get rid of Windows 10 altogether!) and everything is working just fine except for the brightness keys. I just can't get them to work :/

Solutions tried:

  1. xbacklight has always been my goto module but it failed on Fedora installations. I get an error saying no matching display found (I cannot remember the exact error though).

  2. I learned about xrandr using the same trickry as that of xbacklight (or rather the other way around) but it seems like xrandr isn't available in Wayland.

  3. Tried editing GRUB_CMDLINE_LINUX (grub was saved each time) and added (individually),

    1. acpi_backlight=vendor
    2. acpi_backlight=video
    3. acpi_backlight=native
    4. acpi_backlight=
    5. acpi_backlight=none without any success.
  4. (I didn't expect this to work since it has more to do with Xorg) Created 20-intel.conf under /etc/X11/xorg.conf.d with following content,

    Section "Device"
            Identifier  "Intel Graphics"
            Driver      "intel"
            BusID       "PCI:0:2:0"
            Option      "Backlight"       "intel_backlight"
    EndSection
    
  5. Lastly, I tried to create a custom acpi event and registering the combination of function key and Ctrl but I wasn't able to use acpi_listen.

The brightness indicator is working just fine, just the functions don't work. So, I am guessing Fedora is handling brightness behavior just fine, its the keys which are creating trouble.

Disclaimer - I am quite new to Fedora and so it would be great if any commands you share are accompanied by some description. I can 'man' up the rest!

System Info: Asus TP300L (Model), No dedicated graphics card, Kernel 4.8.16

  • I am having this exact same issue with my Asus Zenbook UX310U and have also tried the steps you mentioned. Every other function key except the brightness keys produce ACPI commands and work, but I cant for the life of me get the brightness keys to work – Erin Drummond Jan 14 '17 at 20:40
  • How were you able to see the acpi command for button? I cannot use acpi_listen. It worked on Ubuntu installation though. – Paritosh Jan 15 '17 at 0:31
  • I was able to use acpi_listen, which blocked and then wrote a line of output everytime I pressed a function key. It did this for every function key except the ones that control the screen brightness – Erin Drummond Jan 16 '17 at 1:40
  • Interesting. I cannot even use acpi_listen, keep on getting bash: acpi_listen: command not found... error :/ – Paritosh Jan 16 '17 at 22:49
  • 1
    @ErinDrummond I have the brightness keys working (partially)! Finally. Check the answer but in particular, kernel update (to version 4.9.10) solved it. – Paritosh Feb 22 '17 at 23:03
1

So, apparently something changed with latest Kernel update (i.e. version 4.9.10). Following things are possible now,

  1. Brightness keys are now being registered. I tested it in custom Keyboard setting.
  2. xbacklight is working as expected. No more errors.

Here's what I did,

Mapped F5 and F6 keys (under All Settings -> Keyboard -> Click on '+' indicator) to commands "/usr/bin/xbacklight -inc 5" and "/usr/bin/xbacklight -dec 5" respectively.

The only gripe is function key is still not being registered but I can certainly live with this setup!

P.S - Make sure that xbacklight is indeed installed. Use sudo dnf install xbacklight

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.