I am using ubuntu mate, when I want to access Home directory it shows

The path for the directory containing caja settings need read and write permissions: /home/xxxx/.config/caja

I tried to change permission and restarted it but I get into same problem

  • Can you give a little bit more insight? How do you access the home directory and where appears the error? How were the permissions set for the home folder and how do you change them?... – marc Jan 14 '17 at 0:20
  • I used sudo chmod 777 -R /home/xxxx/.config/caja, it gave results like "changing directory permission: Read only" although I restarted and I was directed to initrafms where I ran "fsck /dev/sda3" and then rebooted it, Right now t is working – sandepp Jan 14 '17 at 18:00
  • Is the partition in read-only mode? You can see that with the mount command. If yes, then remount it with write permission activated sudo mount -o remount,rw /dev/sda3 ... – marc Jan 14 '17 at 18:43

People that came here from Google or Duckduckgo (like me) need the answer on this one. In my case I made a Starter on my Desktop to start Caja filemanager directly from the Desktop. But when I made it executable and click it to run, I get the same message as topic starter above.

For that, I found out a solution, so here it is:

Open a terminal and type: (change username to your username)

cd /home/username/
cd .config
chmod -a -R 777 caja
rm -r caja


Next time the machine starts or Caja filemanager is used, the map caja wil be back in the right mode on /home/username/.config. So don't worry for that.




I encountered this problem after hibernating with the "pm-suspend-hybrid" command in Ubuntu 16.04. Trying to open caja resulted in the same error message you describe. After a reboot and an execution of the fsck command, the problem was fixed in my case, no permission changes required (changing permissions to "777" as per Arno's answer is ill-advised from a security standpoint since "7" permission for "other" means read, write and execute permissions for everyone.)

As to WHY this is happening to prevent recurrences, in this Linux Mint discussion on the topic https://forums.linuxmint.com/viewtopic.php?f=90&t=165741?f=90&t=165741, user "Wharfrat" pins the blame on bypassing ordinary logins with an encrypted drive, which is what happens when I resume from hibernation and wind up directly at my desktop without logging in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.