2

I've disabled all of the secure-boot options (secure boot, legacy boot, fastboot, & even the one in windows which I had to go to power settings & change from hibernation to shutting down).

Here's the error if it'll help:

Error mounting /dev/sda4 at /media/%Username/Windows: Command-line
`mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000"
"/dev/sda4" "/media/%Username/Windows"' exited with non-zero exit
status 14: Windows is hibernated, refused to mount. Failed to mount
'/dev/sda4': Operation not permitted The NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting), or mount the volume read-only with the 'ro' mount
option.

I read online that this is a HP BIOS problem but not one of those posts actually showed how to fix the problem so I though I'd ask myself.

  • This is really two problems in one question. Your answer has nothing to do with the first question, which is a duplicate of unix.stackexchange.com/questions/289527/… – Robin Green May 19 '18 at 14:03
  • @RobinGreen It is not a duplicate. Please see the man ntfs-3g , the remove_hiberfile option. – GAD3R May 19 '18 at 16:27
2

Here are the recommended terminal commands:

sudo mkdir /media/windows
sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda4 /media/windows

it doesn't really do anything bad to the windows partition just allows you to read and write the disk, you might have to write the second command every time you boot to windows and then back to Linux.

1

Try:

sudo ntfsfix /dev/partition_name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.