31

I am using Debian 8.6 LXDE on a Powerbook G4 15" 1.67GHz and would like to enable tap to click on the touchpad. It is already double scrolling but tap to click would help to save the ageing mouse button. Two fingered tap for left click would be the icing on the cake, is this possible?

26

Debian Jessie

To enable the touchpad tapping permanently , copy the 50-synaptics.conf file to /etc/X11/xorg.conf.d then edit it by adding Option "TapButton1" "1" .

As root:

mkdir /etc/X11/xorg.conf.d
cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

The /etc/X11/xorg.conf.d/50-synaptics.conf should be:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "3"

Reboot your system

Debian Stretch and Buster (updated)

Remove the xserver-xorg-input-synaptics package. (important)

# apt remove xserver-xorg-input-synaptics

Install xserver-xorg-input-libinput:

# apt install xserver-xorg-input-libinput

In most cases, make sure you have the xserver-xorg-input-libinput package installed, and not the xserver-xorg-input-synaptics package.

As root:

create /etc/X11/xorg.conf.d/

mkdir /etc/X11/xorg.conf.d

Create the 40-libinput.conf file:

echo 'Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on"
EndSection' > /etc/X11/xorg.conf.d/40-libinput.conf

restart your DM; e,g:

# systemctl restart lightdm

or

# systemctl restart gdm3

Debian wiki : Enable tapping on touchpad

| improve this answer | |
  • 2
    I made the directory and it worked, even two finger tap for right click. Thank you! – Simon Baldwin Jan 19 '17 at 14:50
  • 1
    I think you can restart X instead of the whole system. – Rolf Mar 5 '18 at 1:08
  • 1
    The stretch part is also working for buster – BERA Jul 10 '19 at 19:20
  • 1
    @BERA Thank you. Of course , I will update my answer – GAD3R Jul 10 '19 at 20:16
  • 1
    @GAD3R I later noticed that it was just a setting under "mouse properties" that we've missed. Thank you! – Rodrigo Oct 31 '19 at 16:43
26

In recent systems (2017) as many distros are moving to Wayland, synaptics driver is no longer used. Instead, libinput is used.

To enable tap to click on touchpad using libinput create a file in Xorg config:

$ touch /etc/X11/xorg.conf.d/99-synaptics-overrides.conf

And add the following configuration:

Section  "InputClass"
    Identifier  "touchpad overrides"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"
EndSection
| improve this answer | |
  • 1
    +1 as this is the only way to get tap to click working on Debian Stretch. – user6039980 Oct 20 '17 at 0:10
  • 2
    Worked for me (Debian Stretch, Gnome 3 X11). Also worth noting that it made more options available in Gnome's mouse setting panel (such as tap to click). – Gabriel Devillers Oct 28 '17 at 19:09
  • Upvoted using newly enabled tap-to-click on Debian 9.2. (Though this config did something unexpected to the touchpad's acceleration.) – pdoherty926 Oct 31 '17 at 4:02
  • 2
    @Mephisto Try "TappingButtonMap" "lrm" This option is the mapping for 1, 2 and 3 fingers to left, right, middle click. – Gabriel Molina Feb 12 '18 at 21:55
  • 1
    Worked for me, +1. But I called it 99-touchpad-overrides, as it is generic and my Yoga 370 actually has an Elantech touchpad. – starblue Apr 30 '18 at 10:48
15

This does the trick for me in similar situation under Debian 8.6 and LXDE:

synclient TapButton1=1

Above works if synaptics touchpad work with Synaptics Driver xserver-xorg-input-synaptics.

If you are working with libinput driver (default driver in many live images):

xinput set-prop 'SynPS/2 Synaptics TouchPad' 'libinput Tapping Enabled' 1

You can use xinput list-props 'SynPS/2 Synaptics TouchPad' to see all available properties that can be adjusted for your TouchPad.

If your system uses libinput you can use xinput to find out the name of your touchpad device if the above command doesn't work (they aren't all Synaptics). For example:

Output for xinput:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Video Bus                                 id=6    [slave  keyboard (3)]
↳ Power Button                              id=7    [slave  keyboard (3)]
↳ Sleep Button                              id=8    [slave  keyboard (3)]
↳ Dell WMI hotkeys                          id=9    [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]

Command to enable clicking:

xinput set-prop 'AlpsPS/2 ALPS GlidePoint' 'libinput Tapping Enabled' 1
| improve this answer | |
  • 1
    Yes that works, thank you! Is there a way to make this happen on boot? – Simon Baldwin Jan 13 '17 at 9:58
  • @SimonBaldwin Try to put this line in file /etc/rc.local or to /etc/init.d/rc.local. PS: If you are happy with this answer, don't forget to accept this answer as a solution. – George Vasiliou Jan 13 '17 at 10:43
  • Tried adding to both these files but I still have to enable it manually in the terminal after each boot. Is there any other way of enabling it on boot or login? – Simon Baldwin Jan 13 '17 at 17:19
  • @SimonBaldwin Give a look here : wiki.lxde.org/en/Autostart – George Vasiliou Jan 13 '17 at 23:50
  • @SimonBaldwin for two finger right click try this : $: synclient TapButton2=3 TapButton3=2. Also by running synclient you will see all the options available for touchpad. – George Vasiliou Jan 14 '17 at 0:10
6

Using debian Stretch 9.5 with xfce desktop environment .

update : /usr/share/X11/xorg.conf.d/40-libinput.conf

Add this section:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on"
EndSection

Reboot the system and now tapping should work.

| improve this answer | |
  • I did exactly as per the answer (However I created a backup of the file sudo cp /usr/share/X11/xorg.conf.d/40-libinput.conf{,.bak} before). And it fixed the problems with i3, sddm etc. It's on Debian 9.6. – Ajeeb.K.P Dec 2 '18 at 15:11
  • I did exactly the same thing on Debian 10.2 XFCE and worked perfectly. I suggest you to "reboot your touchpad" device clicking the Fn+F# button if it exists. In my keyboard the button is #=6. Don't try to install another driver for your system, if you can! – Renan Willian Prado Jan 6 at 21:58
3

On Debian 9.1 (stretch) I ran in the same issue (on an asus laptop). I Used LXDE as George.

If you can't find synclient, install first :

sudo apt install xserver-xorg-input-synaptics

Then add the following line at the end of ~/.config/lxsession/LXDE/autostart:

@synclient TapButton1=1 TapButton2=3 TapButton3=2

Reboot and now you can "tap click" and "two fingers tap - right click"

| improve this answer | |
2

This is my synaptic xorg config and works perfectly on Debian 9.7 (stretch) with xserver-xorg-input-synaptics package.

$ cat /etc/X11/xorg.conf.d/70-synaptic.conf
Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"

    ## for natural scrolling
    Option "VertScrollDelta"  "-111"
    Option "HorizScrollDelta" "-111"

    ## tap to click
    Option "TapButton1" "1"

    ## two finger tap to Right click
    Option "TapButton2" "3"
EndSection
| improve this answer | |
0

On Ubuntu 18.04 LTS, the following simple command did the trick:

sudo apt install xserver-xorg-input-synaptics

Then reboot (or restart display manager).

| improve this answer | |
  • 1
    18.04 LTS seems to default to Wayland by default, which may explain why the above command yields an unmet dependency on xserver-xorg-input-synaptics, which isn't installed because xserver-xorg-core isn't installed. I'm scared. – Greg Bell Jan 2 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.