1

Connecting an ASRock Beebox N3000 with Lubuntu 16.04 to a Sony Bravia with a HDMI cable this is the output of xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 735mm x 420mm
   1920x1080i    50.00*+  60.00    59.94  
   1280x720      60.00    50.00    59.94  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       60.00    59.94  
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

1920x1080i is supposed to work well, but it results in a too wide desktop, such that it does not stay within the screen limits. Another laptop connected by VGA performs reasonably well with 1360x768, but this resolution is not supported here. xrandr --addmode HDMI1 1360x768 results in

xrandr: cannot find mode "1360x768"

don't know if this modeline can be added.

I have also tried to change the TV configuration, but there's little to do under a HDMI connection.

0

You can try to adjust the scale.
This is what i usually do when i connect my laptop (res 1366 x 768) to a 1920X1080 TV (mirror mode) using VGA cable. This command worked fine for me , and resolution of TV was pretty good:

xrandr --output LVDS-1 --mode 1366x768 --scale 1x1 --output VGA-1 --same-as LVDS-1 --mode 1920x1080 --scale 0.711x0.711

PS: You might need to experiment a little bit with scale factor

If you want to turn off your laptop screen you could try:

xrandr --output LVDS-1 --off --output VGA-1 --mode 1920x1080 --scale 0.711x0.711

PS2: You might need to change LVDS-1 to your internal laptop monitor name.

Update:

If you want to add a new mode and do not apply the --scale workaround then see this example and also see this post.

$: sudo cvt 1366 768 60
1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

$: sudo xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

$: sudo xrandr --addmode VGA-1 1368x768_60.00
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.