1

I met this problem only with Android-studio, system cmake works fine.

/opt/Android/Sdk/cmake/3.6.3155560/bin/cmake: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/Android/Sdk/cmake/3.6.3155560/bin/cmake)
/opt/Android/Sdk/cmake/3.6.3155560/bin/cmake: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/Android/Sdk/cmake/3.6.3155560/bin/cmake)
/opt/Android/Sdk/cmake/3.6.3155560/bin/cmake: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/Android/Sdk/cmake/3.6.3155560/bin/cmake)

I have run with duckduck and googled but did not found proper solution. How to fix these?

3
  • Did you find a solution? Apr 26, 2017 at 14:14
  • No. But i know a way: use the system CMake with setting toolchain and modules path
    – kyb
    Apr 26, 2017 at 17:57
  • My problem was similar, but not exactly the same. So I think it might be worth linking to this question: stackoverflow.com/questions/43623089/… Apr 27, 2017 at 8:02

1 Answer 1

0

The problem is with old CMake bundled into Android Studio. It refers to an old libssl.
Idea 1. Downgrade libssl
Idea 2. Use system Cmake cross-complilation. https://cmake.org/Wiki/CMake_Cross_Compiling

Todo: describe solutions in details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .