I have recently switched from Ubuntu 12.04 to Debian 8 as support for 12.04 is about to run out. I tried Lubuntu 14.04, Ubuntu Mate 16.04 and Lubuntu 16.04 but couldn't get any of them to run in live mode for any length of time. I have installed Debian 8.6 LXDE and the install went ok and most things work, I have also managed to get Wifi and Bluetooth working but sound has me stumped. Alsamixer opens but shows no sound card. Using terminal I get:

#:~$ aplay --list-devices
aplay: device_list:268: no soundcards found...

and :

#:~$ cat /proc/asound/cards
--- no soundcards ---

Sound works in OSX and worked in Ubuntu 12.04.

Any ideas?

  • Could you post the contents of your kernel dmesg log? Is the snd-powermac driver module loaded? – Jeremy Kerr Jan 13 '17 at 4:19
  • Or perhaps the snd-aoa-* modules, for a PowerBook.... – Jeremy Kerr Jan 13 '17 at 4:24
  • dmesg log is empty. How can I check if these modules have loaded. – Simon Baldwin Jan 13 '17 at 12:06
  • The dmesg.log file may be empty, but just run the dmesg command to get the kernel log. The lsmod command will list loaded modules. – Jeremy Kerr Jan 13 '17 at 12:12
  • Running the sudo modprobe snd-aoa-i2sbus seems to have detected the right soundcard. Now I just need to get it working! Its seems to be using the snd-aoa-* drivers. – Simon Baldwin Jan 13 '17 at 13:14

Non-Free Firmware

If it worked in Ubuntu, but not in Debian, it was probably enabled by some non-free firmware package.

You may need to enable Debian's Non-Free repository in your /etc/apt/sources.list file and do sudo apt-get update, then sudo apt-get install whateverthefirmwarepackageyouneedhere.

This is often the reason that hardware (like Wifi cards) don't work in Debian, but do work in other Linux distributions.

In many ways, Debian values freedom over something working like it's supposed to.

| improve this answer | |
  • AFAIK, none of the powermac audio drivers require external firmware loads. – Jeremy Kerr Jan 13 '17 at 4:20
  • I just tried installing firmware-linux-nonfree. It didn't fix the sound on its own but also made the desktop freeze randomly as in Ubuntu. I then purged it and things returned to normal. – Simon Baldwin Jan 13 '17 at 11:59

The two responses above were helpful and I am not totally sure what sorted it but it seems like the following 2 steps helped:

1) Adding the non-free repository as recommended by Hydraxan14

2) Running sudo modprobe snd-aoa-i2sbus

3) Setting the soundcard to SoundByLayout in alsamixer

Sound is now working, Thank you so much!

| improve this answer | |
  • Having said that, I can't seem to get the settings to happen at every boot up, I have to run the sudo modprobe snd-aoa-i2sbus command every time I want sound. I have added it to the usual boot-up and .profile files but so far no joy! – Simon Baldwin Jan 13 '17 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.