1

Some quick system information: I'm running Arch linux with all the latest software, LDAP is configured and (more or less) working. The autofs maps are stored on an LDAP server and these maps are used by a couple of hundred Ubuntu 14.04 boxes.

Here is the /etc/autofs/autofs_ldap_auth.conf configuration:

<autofs_ldap_sasl_conf
    usetls="yes"
    tlsrequired="yes"
    authrequired="yes"
    authtype="EXTERNAL"
    external_cert="etc/openldap/ca-cert.pem"
/>

on running

# systemctl start autofs

autofs dumps core:

Jan 12 14:55:33 lizard systemd[1]: Starting Automounts filesystems on demand...
Jan 12 14:55:33 lizard systemd[1]: Started Process Core Dump (PID 16463/UID 0).
Jan 12 14:55:33 lizard systemd[1]: autofs.service: Control process exited, code=exited status=1
Jan 12 14:55:33 lizard systemd[1]: Failed to start Automounts filesystems on demand.
Jan 12 14:55:33 lizard systemd[1]: autofs.service: Unit entered failed state.
Jan 12 14:55:33 lizard systemd[1]: autofs.service: Failed with result 'exit-code'.
Jan 12 14:55:33 lizard systemd-coredump[16464]: Process 16458 (automount) of user 0 dumped core.

                                            Stack trace of thread 16458:
                                            #0  0x00007f547ac6804f raise (libc.so.6)
                                            #1  0x00007f547ac6947a abort (libc.so.6)
                                            #2  0x00007f547aca5c50 __libc_message (libc.so.6)
                                            #3  0x00007f547acabfe6 malloc_printerr (libc.so.6)
                                            #4  0x00007f547acac7de _int_free (libc.so.6)
                                            #5  0x00007f5479a265c5 n/a (lookup_ldap.so)
                                            #6  0x00007f5479a2ce78 lookup_done (lookup_ldap.so)
                                            #7  0x000055b1ce49f050 close_lookup (automount)
                                            #8  0x000055b1ce49f934 n/a (automount)
                                            #9  0x000055b1ce4a0632 lookup_nss_read_master (automount)
                                            #10 0x00007f547a2cf267 lookup_read_master (lookup_files.so)
                                              ....

Clearly the application shouldn't dump core, but any thoughts on what I might be doing wrong? Autofs started with no problems when /etc/autofs/autofs_ldap_auth.conf was set to:

<autofs_ldap_sasl_conf
usetls="no"
tlsrequired="no"
authrequired="no"
/>

(i.e. the package default).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.