I am on Fedora 24 with the MATE desktop environment. I did a dnf update and I have noticed now that when I simultaneously press both mouse buttons it acts as if I have clicked middle mouse down.

Is there any way to disable this? I have never noticed this before so I think it may be related to the upgrade I just did. MATE 1.16.1 is running at the moment. Could not find anything when googling/looking through dconf/other settings.

2 Answers 2


On MATE you can set the mouse settings property middle-button-enabled to false to disable the emulation.1 It doesn't disable the middle click altogether.

gsettings set org.mate.peripherals-mouse middle-button-enabled false

Version 1.21 of mate-control-center adds a checkbox for this in the mouse settings.2


From https://ask.fedoraproject.org/en/question/100250/how-do-i-disable-both-button-click-acting-as-middle-click-in-mate/?answer=100309#post-id-100309:

You can disable left+right click acting as middle click for all devices system-wide by adding the file /etc/X11/xorg.conf.d/20-3rdbutton.conf with the following content:

Section "InputClass"
   Identifier "middle button"
   MatchIsPointer "on"
   MatchDriver "libinput"
   Option "MiddleEmulation" "off"

Adapted from the following Stack Exchange answer: https://unix.stackexchange.com/a/284782

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .