0

I have two systems both running RHEL 6.8, each was cloned from the same template but the salt401 system is having a strange issue, the service command does not return anything. I have tried a few different service commands but no results.

I have tested as different users using sudo but same result. I compared the .bash_profiles but they are the same.

For this example I do know that the ssh daemon is running since I can ssh to the system.

[root@salt401 ~]# service sshd status
[root@salt401 ~]#

[root@salt404 ~]# service sshd status
openssh-daemon (pid  2260) is running...
[root@salt404 ~]#

How do I get the service command to output results?

1

Have you tried reinstalling the package containing /bin/env?

# yum reinstall `rpm -qf /bin/env`

You can also check redhat's customer portal.

In addition to reinstalling /bin/env, initscripts also needs to be reinstalled.

# yum reinstall initscripts
  • Package has been reinstalled but same issue. – SpruceTips Jan 12 '17 at 16:41
  • @SpruceTips as mentioned in the above link, if you run "/etc/init.d/sshd status" do you get any output? – blametheadmin Jan 12 '17 at 20:11
  • this command works [root@dnvusalt401 ~]# /etc/init.d/sshd status openssh-daemon (pid 1928) is running... – SpruceTips Jan 16 '17 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.