2

I have been trying to install arch on my mid-2011 Macbook air, I moved the ISO to an 8GB USB-Drive with:

dd bs=4M if=/home/ronnie/Downloads/archlinux.iso of=/dev/sdb status=progress && sync

Then, I restart and get the rEFInd boot-loader and have four choices to boot from the liveUSB. The first one is a tux icon which takes me to:

rEFInd - Booting OS

Starting vmlinuz-arch.efi

Using load options

and hangs there no matter how long I wait.

The second choice, which says EFI\bootloader\ and the third one which is a flashback both give me a list and when I chose

Arch-anywhere x86-64

it goes into a blank screen and nothing happens, I have to press and hold the power button to shut my Mac down.

I tried many other ways, like Architect and Antergos even the official arch ISO from their website and I still get the same problem.

I can boot from Legacy mode though.

How can I install Arch in EFI mode on my mac?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.