2

I have a new Red Hat Enterprise Linux Server release 7.3, I am trying to install Ambari Server on this machine by following the steps in the link

http://docs.hortonworks.com/HDPDocuments/Ambari-2.1.0.0/bk_Installing_HDP_AMB/content/_download_the_ambari_repo_lnx7.html

I am able to run the first step i.e

wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.1.0/ambari.repo -O /etc/yum.repos.d/ambari.repo

But when I am executing the next steps yum repolist or yum install ambari-server I am getting the following error.

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager


rhn-plugin: RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running 

        rpm --rebuilddb

I ran the above command but it did not solve my problem. I tried to search for the answer but I did not find anything on the internet.

Can anyone identify this problem?

5
  • uname -a and /etc/issue please
    – schaiba
    Jan 12, 2017 at 11:59
  • Output of uname -a Linux <machinename>.corporate.local 3.10.0-514.2.2.el7.x86_64 #1 SMP Wed Nov 16 13:15:13 EST 2016 x86_64 x86_64 x86_64 GNU/Linux Jan 12, 2017 at 12:03
  • @Ravi, You used RHEL 7.3 but the repo just supported RHEL 7.2.The repo didnt support RHEL 7.3 yet.You got this error "Could not determine what version of Red Hat Linux you are running."
    – supriady
    Jan 12, 2017 at 17:24
  • @Ravi, You used RHEL 7.3 but the repo just supported RHEL 7.2.The repo didnt support RHEL 7.3 yet.You got this error "Could not determine what version of Red Hat Linux you are running."
    – supriady
    Jan 12, 2017 at 17:25
  • is there any way out of this problem except waiting for yum to support 7.3? Jan 16, 2017 at 5:08

0

You must log in to answer this question.

Browse other questions tagged .