I have a weird xfce panel behavior. Sometimes when I login to my system, after a few seconds (2-3) my panel (I have only one @ the bottom) disappears. But it's there..
For example if I hit atl+f1 the application menu pops-up and I can select w/e I want. Also if I try to run the xfce4-panel nothing happens.
My solution is to log out and log in again and the panel then does not disappear.
I have to mention here that there was not any "Save session for future use" lately. Just asking in case anyone had the same problem if he/she managed to solve it.
I am running Arch and the only change that I have made was to add "dbus-launch" parameter inside my .xinitrc file, and now it looks like:

exec dbus-launch startxfce4

I have altered the .xinitrc file because I had issues with a shared (Windows) directory in the network and that was the only solution in order to view the content of the shared directories.

Thanks in advance.

  • Just to start with the obvious, in Panel Preferences, what do you have selected for "Automatically hide the panel"? If it's anything other than never, then I would set it to never for troubleshooting. I just wanted to verify this before digging deeper. I am running xfce4 on Arch Linux and have never seen exactly this problem before. Also, could you further explain your statement "But it's there..."? The default key-binding of alt+F1 is to launch xfce4-popup-applicationsmenu, regardless of whether you have a panel or not. – airhuff Jan 13 '17 at 3:21
  • @airhuff "Automatically hide the panel" option is already set to "Never". By "but it's there" I mean that when alt+f1 to launch xfce4-popup-applicationsmenu, I guessed that the panel was there because the xfce4-popup-applicationsmenu is visible in the left bottom corner (just like the spot that it is when panel is visible). So from this I assumed that the panel is there, otherwise the xfce4-popup-applicationsmenu would open in a random place, or not? – blametheadmin Jan 13 '17 at 7:49
  • Depending on your settings, Alt+F1 is likely placing the pop-up application menu under your mouse pointer. Regardless, you don't need a panel for xfce4-popup-applicationsmenu to run. There might be some further point of confusion because the xfce4-popup-applicationsmenu command is owned by xfce4-panel. Try running ps -A |grep xfce4-panel to see if the panel is really running. If that command returns nothing then the panel is not running, and then we figure out why! Otherwise it's running invisibly and then we have to figure out why ;) – airhuff Jan 13 '17 at 8:26
  • @airhuff Okay, I will try to reproduce the issue with a shutdown. Also, If I remember right, when this happens, if I open a program eg. firefox or a terminal emulator or w/e, there is no title bar (and min, max, close buttons) in any of them. – blametheadmin Jan 13 '17 at 10:08
  • @airhuff okay I managed to reproduce it. xfce4-panel is running. Also what I observed in my last test, was that conky is not visible. But, when I press Alt+F1 and then logout, when I press the logout button, for that little time (less than 1 sec) before the current session is finished, conky is visible (as it should be from the beginning).. I am starting conky from "Application Autostart" under "Session and Startup" settings and it's enabled. – blametheadmin Jan 13 '17 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.