8

How can I disable white noise in Dell XPS 13 when headphones to 3.5mm audio jacket are connected?

Every time time I connect headphones to 3.5mm audio jacket I hear constant white noise from headphones. Looks like this problem has been fixed for some XPS models but not for all. I spent quite a lot time trying to find solution for it so I decided to share it to make life easier for you.

closed as unclear what you're asking by Kusalananda, Jeff Schaller, Dmitry Grigoryev, countermode, John WH Smith Jan 12 '17 at 22:18

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • please do not add answers to the question body. instead create a new answer and accept it (so the issue gets properly closed) – umläute Jan 12 '17 at 11:10
  • Why is your microphone enabled when you're not using it? – Dmitry Grigoryev Jan 12 '17 at 11:12
  • @DmitryGrigoryev It doesn't matter if the headset mic is on or off the white noise is still there. – Henri Koski Jan 12 '17 at 11:47
  • 4
    erm why is this unclear? this is very much a legit issue on XPS 13s. classic tryhard stack exchange mods – Austin Adams Jan 27 '18 at 16:27
16

Set Headphone Mic Boost gain to 10dB. Any other value seems to cause the irritating background noise in headphones. This can be done with amixer:

amixer -c0 sset 'Headphone Mic Boost' 10dB

To make this happen automatically every time you headphones are connected install acpid.

Start it by running: sudo systemctl start acpid.service

Enable it by running: sudo systemctl enable acpid.service

Create following event script /etc/acpi/headphone-plug

event=jack/headphone HEADPHONE plug
action=/etc/acpi/cancel-white-noise.sh %e

Then create action script /etc/acpi/cancel-white-noise.sh:

#! /bin/bash
amixer -c0 sset 'Headphone Mic Boost' 10dB

Now Headphone Mic Boost will be set to 10dB every time headphones are connected. To make this effective you need to restart your laptop.

  • 4
    This works with a slight modification on ubuntu 16.04. The headphone-plug event script should be in /etc/acpi/events instead and this doesn't need a chmod +x The cancel-white-noise.sh path should work as mentioned above, but the file needs a chmod +x After setting them up, run sudo service acpid restart. Worked for me without a restart. Thanks :) – Gaurav Apr 12 '18 at 19:47
  • Thanks a lot. This solution also worked for me on Ubuntu 18.04.3. Baffling that the question is closed. – Roald Sep 28 at 7:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.