0

I used to use infinality for good-looking fonts, but it hasn't been updated for ages, and it's now broken. I've since reverted to vanilla freetype and vanilla fonts. I followed instructions to get fonts looking reasonable, specifically, creating /etc/fonts/local.conf as per here. I also appended the following line to /etc/profile.d/jre.sh

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true'

Some of my java apps are fine, but some (e.g. Jabref) look terrible. It looks like the subpixel rendering if totally off. (Previously, with infinality, they looked excellent.)

Jabref

As per the Arch wiki, I tried a few different options, such as setting -Dawt.useSystemAAFontSettings to lcd, gasp and off. However, none of these helped. I also tried using different version of java (java-7-openjdk, java-8-jre/jre and java-8-openjdk), but this didn't help either.

Finally, I tried to install jre{7,8}-openjdk-infinality, but they appear to require "infinality support in FreeType", which is obviously now missing. Can I fix this poor rendering in Jabref?

(Originally asked here, with no response.)

1

You need a version of openjdk which is built with the freetype support, such as tuxjdk (don't know if it is still supported) or jetbrains' openjdk (available in AUR). And I think it is possible to use the infinality openjdk, with broken dependencies, because its only difference from the original is freetype support (I may be wrong on this).

2
  • Thanks. tuxjdk wouldn't build for me, but I could install intellij-jdk. I selected it with archlinux-java, but unfortunately it made no difference. I also tried installing jdk8-openjdk-infinality, and it actually worked this time. It both installed and fixed this issue. I'll +1 but not accept this answer, because I'd really like a non-Infinality solution, since it's probably only a temporary fix. Cheers.
    – Sparhawk
    Jan 12 '17 at 11:27
  • May be there are differences between openjdk bundled with a jetbrains IDE and that in AUR, because the bundled one works for me just fine. I don't use any other standalone java apps, so I didn't try the one in AUR, just assumed they are identical. Jan 12 '17 at 13:20
0

Ends up that it was just a bug in the Jabref launcher, and my selected java wasn't being used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.