Recently tried installing both latest ApricityOS and Fedora 25 (gnome versions). The cursor freezes in the top left corner. I can still click on things (if I guess correctly). Everything else seems to work fine. I've got an Nvida GTX1080 which I suspect is the problem. I've read that there are some issues with nouveau and the Pascal series, and issues with Wayland and Nvidia. Does anyone know how I can get either working?

  • You mean the mouse cursor? Is the mouse, in fact, functional? – Kusalananda Jan 11 '17 at 14:23
  • The mouse works fine. Tested it on another PC. The mouse arrow just stays top left, but if you move the physical mouse, things will get the mouse-over animation and you can click on things. But during this, the cursor will not move. – TheRoyalTnetennba Jan 11 '17 at 14:24
  • Other things I've tried: Different mouse. Unplugging and replugging the mouse. Multiple new install USB creations. On ApricityOS live, installing the nvidia drivers (kinda of dumb probably but I thought I'd check). – TheRoyalTnetennba Jan 11 '17 at 14:33

I ran into the same issue, and found the solution here:


To summarize:

First, you'll have to install Fedora using the keyboard. Slightly annoying, but not too hard.

Then, after you're installed and booted, run the following:

sudo dnf config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo
sudo dnf upgrade
sudo dnf install nvidia-driver nvidia-settings kernel-devel

Finally, restart, and you should have a mouse.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.